[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC1 -> FC3 ,gnome, "Error activating XKB configuration"

	Well, Bob's suggestion didn't work for me.
I have now read the Bugzilla reports.
Still puzzled as to why I get an error on this system.

I notice that the '/usr/X11R6/lib/X11/xkb/rules/xorg file still contains a few references to 'xfree86' as in;
!model = keycodes
* xfree86

In 'xorg.conf' I decided to try to add the line:

"XkbOptions" "xorg"

even though the output of 'gconftool-2...' indicates 'xorg' is used.

When I restarted the system after this, Kudzu had decided that I had removed a second USB node, and that I had installed a new mouse and keyboard. I was hopeful that this would do the trick. But alas, I still get the same error box.
Interestingly, the system must have regenerated the 'xorg.conf' file, because my addition to it was gone.

So, am I now the only person who still has this problem?

I did an upgrade of FC1 -> FC3 on a P4, Intel845 board, Rage 128, PS2 mouse and PS2 pc105 keyboard.

Trying to run the gnome desktop gives the error:

"Error activating XKB configuration"
"Probably internal X server problem"
"XServer version data: Xorg Foundation 60801000
"If you report this, include results of:
"	xprop -root | grep XKB"
"and    gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb"

The result of the 'xprop' is;

Regarding the second command that is suggested, I assume it means to look in '~/.gconf/gnome/peripherals/keyboard.'
I notice there is only a 'xkb.backup' file there.


Note, while I am not a 'KDB' user, that desktop runs just fine.

Has anyone else encountered this?

	Henry Leparskas

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]