[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora Project launches Pre-Extras



On 12/16/2004 11:00:26 AM, seth vidal wrote:


So how do I get it? Pre-Extras is currently hosted on the FedoraProject.org website, and is available at:

http://fedoraproject.org/pre-extras/3/

It is available as a YUM repository, and an entry like the following
would suffice (in /etc/yum.conf):

[pre-extras]
name=Pre Extras
baseurl=http://fedoraproject.org/pre-extras/3/$basearch/
gpgcheck=1

There is a temporary Pre Extras GPG key, which all packages are signed
with. The fingerprint:


pub  1024D/1AC70CE6 2004-12-14 Fedora Pre Extras Release
<pre-extras fedoraproject org>
     Key fingerprint = 5389 DD00 C5BC 5168 12B4  3272 82ED 9504 1AC7
0CE6
sub  1024g/4E1A9D43 2004-12-14

To import the key:

rpm --import http://fedoraproject.org/pre-extras/RPM-GPG-KEY-Fedora-Pre-Extras


What about bugs?
If you find bugs in the packages, report them at the Fedora Extras
Bugzilla:

Don't know if this is a bug in the package or a bug in yum ...
during yum update, to update packages I have that are rebuilds of fc2 src.rpms -


--> Running transaction check
--> Processing Dependency: aalib = %{epoch}:1.4.0-0.rc5.2 for package: aalib-devel
Traceback (most recent call last):
File "/usr/bin/yum", line 7, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 104, in main
(result, resultmsgs) = base.buildTransaction()
File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 219, in buildTransaction
(rescode, restring) = self.resolveDeps()
File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 187, in resolveDeps
(checkdep, missing, conflict, errormsgs) = self._processReq(dep)
File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 271, in _processReq
CheckDeps, missingdep = self._requiringFromTransaction (requiringPkg, requirementTuple, errormsgs)
File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 420, in _requiringFromTransaction
provSack = self.whatProvides(needname, needflags, needversion)
File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 65, in whatProvides
(r_e, r_v, r_r) = rpmUtils.miscutils.stringToVersion(version)
File "/usr/lib/python2.3/site-packages/rpmUtils/miscutils.py", line 307, in stringToVersion
epoch = string.atol(verstring[:i])
File "/usr/lib/python2.3/string.py", line 236, in atol
return _long(s, base)
ValueError: invalid literal for long(): %{epoch}


I'm running yum-2.1.12-1
I'll try downgrading yum to Fedora version and see if that helps.

My repositories -

3 livna's
2 JPackage's
some repositories of my own creation that are suppose to depend up extras and the 3 livna's




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]