[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Re: Installing Fedora from ISO Images



>On Thursday 01 January 2004 04:15, David Hunt wrote:
>> I am currently running Windows XP / Mandrake 9.1 on a Dell Inspiron 5100.
I
>> was planning on upgrading to Mandrake 9.2 (mainly for ACPI) and decided
to
>> give Fedora a try. Well that's the preample. But, here is the catch. I
>> didn't pay for the external floppy drive, or a CD writer. So, I've
>> downloaded the ISO images, I have verified the MD5SUM, I can even mount
the
>> images and view the files inside. But as far as I can tell, without
writing
>> the images to a CD, it appears that I can't do anything usefull with
them.
>> It seems like it should be possible to mount the images during the
install
>> process, instead of the CD-ROM. Has anyone ever tried that?
>>On Thu, 1 Jan 2004 16:59:14 Mihai Maties wrote:
>Boot up Mandrake 9.1 and then issue the commands:
>
>mount /first/fedora/iso/image.iso /mnt/cdrom -o loop
>mount /mnt/cdrom/images/bootdisk.img /mnt/floppy -o loop
>mkdir /boot/fedora
>cp /mnt/floppy/vmlinuz /boot/fedora
>cp /mnt/floppy/initrd.img /boot/fedora
>
>now add the following lines to your grub.conf file:
>
>title - Install Fedora Core 1 -
>root (hd0,1)
>kernel /boot/fedora/vmlinuz
>initrd /boot/fedora/initrd.img
>
>Pay attention to the "root (hd0,1)" part and change it to match the
"root..."
>part from the Mandrake installation.
>
>That's it, now reboot your computer and select "Install Fedora Core 1" from
>Grub's menu. After a few dialogs you will be asked to enter the path to the
>Fedora Core iso images so make sure you'll remember it. Also note that the
>iso images cannot be loaded from a NTFS partition ( if you have the images
on
>a Windows partition move them to one of Mandrake's partitions).
>
>
>Mihai
>


Thank you very much for all of the help. This was my first post to a Linux
mailing list, and the response was great. Of course, best of all, it solved
my problem. I'm a little confused as to how to respond to these emails. It
is not obvious that this will end up in the right place. But, here it goes.

I tried the advice of Mihai (included above), since it was the closest to
how I was thinking it would be done. For my specific setup, there were only
a few deviations.

1.I have no floppy drive, so there was no /mnt/floppy directory. Without a
pre-existing directory the mount command didn't work. After simply adding
the empty directory, the mount command worked fine.

2. I currently use LILO, but making the changes to /etc/lilo.conf was easy
enough. I don't know if it is required, but with LILO, it is necessary to
type in "lilo" at the command prompt, after changing the lilo.conf file, for
the changes to actually take effect.

3. One more thing. The .ISO files have to be in the root "/" directory of
the partition in which they are located. When they were in a lower level
directory, the installer wouldn't find them.

So, end result was exactly what I was looking for. The install from the ISO
files appeared to be working. Unfortunately the work isn't done. During the
install everything crashed. There was a big list of failures, having to do
with dev/hd issues (write permissions, formatting?). I didn't copy them down
as I should have, and can't get now because Mandrake was destroyed in the
process. I will be re-loading Mandrake, and following the process again. I
will try to get better failure information, and verify that it didn't have
anything to do with the install process. The ISO files were on a FAT32
partition (not NTFS, but also not a Linux partition), which may have had
something to do with it.

Thanks.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]