Fedora Core 2 upgrade FAILURE

Richard Emberson remberson at edgedynamics.com
Tue Jun 1 15:09:58 UTC 2004

I have an older machine that can not boot from cdrom. Also, I had
some user data in one of the accounts.

So I mounted disc1, copied vmlinuz and initrd.img to /boot, unmounted
disc1, added entry to /etc/grub.conf, then rebooted:

mount /dev/cdrom
cp -a /mnt/cdrom/isolinux/vmlinuz /boot/FC2-install
cp -a /mnt/cdrom/isolinux/initrd.img /boot/FC2-install.img
umount /mnt/cdrom
and add entry like:
title Fedora Core 2 Installation
         root (hd0,0)
         kernel /FC2-install
         initrd /FC2-install.img
to /etc/grub.conf (use /boot/FC2... when not relative to /boot)

Everything was going along fine; I did an upgrade (not install) and 
after 1 1/2 hours it said that the installation was a success and that
I should click the reboot button ... which I did.

Well, reboot started out ok, there was a single boot option on the
grub boot page, but then it asked me to insert disc1. I did so
and it then asked me if I wanted to upgrade or install.


I selected upgrade and it proceeded to "upgrade" a php rpm from disc1
and compat-db rpm from disc3 and announced that the installation was
successful and that I should click on the reboot button.

Ok, reboot started and then once again it requested that I insert disc1
and once again it installed the same two rpm's, php from disc1 and
compat-db from disc3 and announced that the installation was a success.

I tried one more time with the same result.

So how do I break out of this? I really dont care about either
php or compat-db, I'd like to somehow bypass installing them and
get on with the boot. Are there parameters one can give at the grub
command line to force a kernel load?

Help! Thanks.


More information about the fedora-list mailing list