Fedora Core 2 upgrade FAILURE

Richard Emberson remberson at edgedynamics.com
Mon Jun 7 19:50:25 UTC 2004

SUCCESS (see below)

Richard Emberson wrote:
> I have an older machine that can not boot from cdrom. Also, I had
> some user data in one of the accounts.
> So I mounted disc1, copied vmlinuz and initrd.img to /boot, unmounted
> disc1, added entry to /etc/grub.conf, then rebooted:
> mount /dev/cdrom
> cp -a /mnt/cdrom/isolinux/vmlinuz /boot/FC2-install
> cp -a /mnt/cdrom/isolinux/initrd.img /boot/FC2-install.img
> umount /mnt/cdrom
> and add entry like:
> title Fedora Core 2 Installation
>         root (hd0,0)
>         kernel /FC2-install
>         initrd /FC2-install.img
> to /etc/grub.conf (use /boot/FC2... when not relative to /boot)
> Everything was going along fine; I did an upgrade (not install) and 
> after 1 1/2 hours it said that the installation was a success and that
> I should click the reboot button ... which I did.
> Well, reboot started out ok, there was a single boot option on the
> grub boot page, but then it asked me to insert disc1. I did so
> and it then asked me if I wanted to upgrade or install.
> hmmm.....
> I selected upgrade and it proceeded to "upgrade" a php rpm from disc1
> and compat-db rpm from disc3 and announced that the installation was
> successful and that I should click on the reboot button.
> Ok, reboot started and then once again it requested that I insert disc1
> and once again it installed the same two rpm's, php from disc1 and
> compat-db from disc3 and announced that the installation was a success.
> I tried one more time with the same result.
> So how do I break out of this? I really dont care about either
> php or compat-db, I'd like to somehow bypass installing them and
> get on with the boot. Are there parameters one can give at the grub
> command line to force a kernel load?
> Help! Thanks.
> Richard

Thanks to the many replies.

What I ended up doing ....

My original system had two scsi disks: disk1 with /boot and /
and the other, disk2, with /home and /usr/local and I did not want to
lose /home and /usr/local - which is why I wanted to upgrade,
not install.

So I bought a new scsi (I do plan to build a new machine at home
some time this Summer, so its not as extreme as one might think)
using it to replace disk2
and did a redhat 9.0 on my old machine.
I then mounted FC2 disc1 and copied vmlinux and initrd as described
above. I then via grub booted using the FC2 code and did a full
install. It worked. Now I can just replace the new disk2 with the
old and the upgrade is complete.

IMPORTANT: the first time I did this - yes I did this twice - I
for some unknown reason had disk1 contain /boot and /usr while
the new disk2 had / - the redhat 9 install succeeded this succeeded but
not the subsequent FC2 install!! - so the second time I had disk1
contain /boot and / while the new disk2 had /home and /usr/local and
for this combination FC2 install (after installing redhat 9 a
second time) worked.

Thanks again.


More information about the fedora-list mailing list