Using VMWare with FC2

Bob Crosson rcrosson at
Tue Jun 8 11:50:07 UTC 2004

I run VMWare 4.5.1 on top of FC2 with Windows 2000 as the guest 
operating system.  These same functions all worked fine with FC1.  I can 
use my CD reader/writer fine in FC2 after adjusting for the new way of 
accessing the drive (no more hdc=ide-scsi), but when I try to read a CD 
in W2K, it thinks the CD is a music CD and automatically starts the CD 
player.  The CD player eventually dies because it can't read the CD. 
There's no way I can get W2K to think the CD contains data.

My CD drive is /dev/cdrom -> /dev/hdc.  In FC1 I used "hdc=ide-scsi" and 
the CD drive was /dev/cdrom -> /dev/scd0.  I don't remember if the 
ownership of /scd0 in FC1 belonged to my user account (as opposed to 
root), but /dev/hdc in FC2 now belongs to my user account.  I don't know 
if this has anything to do with the problem.  I tried VMWare with the CD 
drive setting ide0:0 pointing to /dev/cdrom and /dev/hdc, but neither 
worked.  I haven't tried the legacy setting yet.  I did try mounting a 
data CD in FC2 first, when accessing it from W2K, but it didn't work either.

Everything else I've tried in W2K seems to work fine.  Any help would be 
greatly appreciated.

Bob Crosson
rcrosson at

More information about the fedora-list mailing list