[FC2] Extend root LVM Volume

Mark Miksis mark.nospamplease at miksis.com
Thu Jun 17 14:30:35 UTC 2004

Trond Are Haugland wrote:
> Mark Miksis wrote:
>> I'm trying to extend a root LVM volume (ext3) using the FC2 rescue CD.
>> When I try to run resize2fs, it cannot see the volumes.  vgscan also does
>> not find anything.  What am I missing?
> What's the command? Any error messages?
>> Otherwise everything seems normal and I was able to run lvextend with no
>> problem.
> If you can use lvextend, then vgscan/vgchange has to have been run
> successfully, no?

Let me clarify.  I ran lvextend when the system was booted normally and 
the volumes were mounted.  This worked as expected.

Then I booted into the FC2 rescue CD and instructed it to NOT search for 
and mount Fedora installations.  I then ran:
# resize2fs /dev/Volume00/LogVol00
I don't have the specific error, but it basically says that the 
specified volume doesn't exist.  Indeed if I look in /dev, my volume 
group and volumes are nowhere to be found.

At that point I tried:
# lvm
lvm> vgscan
After only about 1 second, it responds that no volumes are found.

I also tried rebooting from the CD and letting it mount my 
installations.  In this case, the volume and volume groups are properly 
dscovered and mounted.  However, if I try to unmount the volume, it 
always responds with "device busy".

More information about the fedora-list mailing list