Perl script doen't work for a specific user [SOLVED]

Scot L. Harris webid at
Thu Jun 24 16:17:48 UTC 2004

On Thu, 2004-06-24 at 11:56, Patrick Nelson wrote:
> > The message above seems to indicate a possible path or permissions
> > problem.
> > 
> > Since you have one system that works and one that doesn't then you can
> > compare both setups to see what is different.  Start by looking for the
> > file.  Here it is owned by root and has 644 permissions.
> Wow, you were right.  I never thought of looking at the permissions (OMG
> I've been bit by that before).  These were two systems that were built
> side by side with the standard rpms...  Yet you were right I walked
> through the spamassassin perl and lib dirs and all the sub-dir were in
> fact 700.  Arg, but I changed them and it worked...  Thanks.

You don't have to sound so surprised!  :^D

Glad that led to a fix for you.  You might want to check the umask of
the user you installed the rpms as.  (probably root)  Not sure if that
will affect the permissions on files installed via an rpm or not.  I
don't think it should but worth checking.

The other possibility is that someone ran a recursive chmod on the one
box by accident and changed them.  If it happened recently check the
history log of root for chmod commands.  This is more likely where the
problem came from IMHO.

Spamassassin is a great tool.  Now if we can only get it to actually
kill the spammers......

Scot L. Harris
webid at

Majority, n.:
	That quality that distinguishes a crime from a law. 

More information about the fedora-list mailing list