[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Advice on Aironet Cisco Wireless on IBM T41 and PCMCIA slots not working.



Hi All,

I have an IBM T41 laptop that has a built in Aironet Wireless adapter. I
have loaded FC2 final from scratch and am having some difficulties in
getting it going. 

Here are some messages from /var/log/messages:


Jun  2 20:18:01 i99tvxnb kernel: airo:  Probing for PCI adapters
Jun  2 20:18:01 i99tvxnb kernel: airo: Firmware version 5.20.17 is not
supported. Use it at your own risk!
Jun  2 20:18:01 i99tvxnb kernel: airo: MAC enabled eth0 0:2:8a:ea:66:3e
Jun  2 20:18:01 i99tvxnb kernel: airo:  Finished probing for PCI
adapters
Jun  2 20:18:01 i99tvxnb kernel: Intel(R) PRO/1000 Network Driver -
version 5.2.39-k2
Jun  2 20:18:01 i99tvxnb kernel: Copyright (c) 1999-2004 Intel
Corporation.
Jun  2 20:18:01 i99tvxnb kernel: eth1: Intel(R) PRO/1000 Network
Connection
Jun  2 20:18:01 i99tvxnb kernel: airo: Unregistering eth0
Jun  2 20:18:01 i99tvxnb kernel: ip_tables: (C) 2000-2002 Netfilter core
team
Jun  2 20:18:01 i99tvxnb kernel: airo:  Probing for PCI adapters
Jun  2 20:18:01 i99tvxnb kernel: airo: Firmware version 5.20.17 is not
supported. Use it at your own risk!
Jun  2 20:18:01 i99tvxnb kernel: airo: MAC enabled eth0 0:2:8a:ea:66:3e
Jun  2 20:18:01 i99tvxnb kernel: airo:  Finished probing for PCI
adapters

I can configure the interface ok , but when it activates here are the
messages from /var/log/messages.

Jun  2 20:35:22 i99tvxnb kernel: Setting key 0
Jun  2 20:35:23 i99tvxnb kernel: airo: Max tries exceeded waiting for
command
Jun  2 20:35:23 i99tvxnb kernel: PC4500_writerid: Write rid Error 65535
Jun  2 20:35:23 i99tvxnb kernel: PC4500_writerid: Cmd=0121
Jun  2 20:35:23 i99tvxnb kernel: airo:  WEP_PERM set ffff
Jun  2 20:35:23 i99tvxnb kernel: airo: cmd= 1
Jun  2 20:35:23 i99tvxnb kernel: airo: status= 7f21
Jun  2 20:35:23 i99tvxnb kernel: airo: Rsp0= 4
Jun  2 20:35:23 i99tvxnb kernel: airo: Rsp1= 0
Jun  2 20:35:23 i99tvxnb kernel: airo: Rsp2= 0
Jun  2 20:35:23 i99tvxnb kernel: airo: cmd= 2
Jun  2 20:35:23 i99tvxnb kernel: airo: status= 7f02
Jun  2 20:35:23 i99tvxnb kernel: airo: Rsp0= 0
Jun  2 20:35:23 i99tvxnb kernel: airo: Rsp1= 0
Jun  2 20:35:23 i99tvxnb kernel: airo: Rsp2= 0
Jun  2 20:35:23 i99tvxnb kernel: ip_tables: (C) 2000-2002 Netfilter core
team
Jun  2 20:35:23 i99tvxnb dhclient: sit0: unknown hardware address type
776
Jun  2 20:35:24 i99tvxnb dhclient: sit0: unknown hardware address type
776
Jun  2 20:35:27 i99tvxnb dhclient: DHCPDISCOVER on eth0 to
255.255.255.255 port 67 interval 3
Jun  2 20:35:30 i99tvxnb dhclient: DHCPDISCOVER on eth0 to
255.255.255.255 port 67 interval 3
Jun  2 20:35:31 i99tvxnb dhclient: DHCPDISCOVER on eth0 to
255.255.255.255 port 67 interval 6
Jun  2 20:35:33 i99tvxnb dhclient: DHCPDISCOVER on eth0 to
255.255.255.255 port 67 interval 5
Jun  2 20:35:37 i99tvxnb dhclient: No DHCPOFFERS received.

Of course, the wireless functions ok under THAT  other operating syste,
so I know my network infrastructure is ok. The wireless light does blink
on the laptop so I guess something is happening - I did have RHEL 3 ES
loaded on the laptop for a short while, but that distro refused to even
recognise the wireless adapter - at least FC2 knows it's ther ..... :) -
anyone have ideas or point me in the right direction ? 

BTW, on another unrelated problem, FC2 Final refuses to see my PCMCIA
slots - the yenta module is loaded and pcmcia services start - but
insertion of a pcmcia card doesnt get the normal 2 beeps that one
excpects  -  nothing happens at all - no messages in syslog either - 
another bug ??

Thanks in advance,

Peter Z.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]