[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora Core 2 upgrade FAILURE



Phil Schaffner wrote:
On Tue, 2004-06-01 at 08:09 -0700, Richard Emberson wrote:

I have an older machine that can not boot from cdrom. Also, I had
some user data in one of the accounts.

So I mounted disc1, copied vmlinuz and initrd.img to /boot, unmounted
disc1, added entry to /etc/grub.conf, then rebooted:

mount /dev/cdrom
cp -a /mnt/cdrom/isolinux/vmlinuz /boot/FC2-install
cp -a /mnt/cdrom/isolinux/initrd.img /boot/FC2-install.img
umount /mnt/cdrom
and add entry like:
title Fedora Core 2 Installation
        root (hd0,0)
        kernel /FC2-install
        initrd /FC2-install.img
to /etc/grub.conf (use /boot/FC2... when not relative to /boot)

Everything was going along fine; I did an upgrade (not install) and after 1 1/2 hours it said that the installation was a success and that
I should click the reboot button ... which I did.


Well, reboot started out ok, there was a single boot option on the
grub boot page, but then it asked me to insert disc1. I did so
and it then asked me if I wanted to upgrade or install.

hmmm.....

I selected upgrade and it proceeded to "upgrade" a php rpm from disc1
and compat-db rpm from disc3 and announced that the installation was
successful and that I should click on the reboot button.

Ok, reboot started and then once again it requested that I insert disc1
and once again it installed the same two rpm's, php from disc1 and
compat-db from disc3 and announced that the installation was a success.

I tried one more time with the same result.

So how do I break out of this? I really dont care about either
php or compat-db, I'd like to somehow bypass installing them and
get on with the boot. Are there parameters one can give at the grub
command line to force a kernel load?

Help! Thanks.


Hummm... Looks like anaconda didn't correctly update the bootloader,
which should have been the default.  Did you tell it not to update GRUB
during the upgrade?  Possible confusion between MBR and boot record of
the active partition?  If you did request that the bootloader be
updated, and don't find another head-slapper cause, then this is one for
Bugzilla.

You should be able to recover either by booting from the rescue disk
image and following directions, or by using the command line in GRUB.
GRUB command-line completion with TAB should help.

At the menu type "c" for a command line, then assuming a standard
kernel, /boot is /dev/hda1, and / is labeled:

root (hd0,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/
initrd /initrd-2.6.5-1.358.img
boot

If you get it started, then add the following stanza
to /boot/grub/grub.conf

title Fedora Core (2.6.5-1.358)
        root (hd0,0)
        kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/1 rhgb quiet
        initrd /initrd-2.6.5-1.358.img

May need to run "grub-install" if the boot device (e.g. MBR vs. active
partition) is/was incorrect.

Phil




Interestingly, I do not have initrd-2.6.5-1.358.img in my /boot directory. I do have the previous 2.4.x initrd version, but not the 2.6.x version. (I also do not have the file memtest86+-1.11 ... comparing the contents of the failed upgrade machine's /boot directory to a successfully installed machine's /boot directory).

Also, grub does not have the networking commands, e.g., ifconfig, so
I can not try a network-base access to initrd-2.6.5-1.358.img on
some other machine.

Is there a way to read initrd-2.6.5-1.358.img from the cdrom disc1
or the rescue disc? Either read it and put it into the /boot directory
or somehow reference the cdrom as a directory path root in the grub
command line?

Again, my old VALinux machine does not allow booting from a cdrom.

Thanks

Richard



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]