[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Beep gone in FC2?



Dave Ulrick wrote:

On Wed, 2 Jun 2004, Joshua Andrews wrote:



After inserting the module I have a beep in a tty and in gnome-terminal,
as root, but KDE apps refuse to beep.
I have tried everything I can think of, all the settings I can find.

If I "run command" from the main menu; `echo $'\a'` I get a beep but so
far that is it. In konsole if I run the same command all I get is a bell
icon no beep no matter what the system bell settings are adjusted to in
konsole configuration or in Control Center bell configuration.

It may be very Pavlovian but I sure miss those beeps!



To get a PC speaker beep from all KDE apps, bring up Control Center, then look for the System Bell item. You want to tell KDE to _not_ use system notification for bell events. I think you uncheck a box to do this. Once you uncheck it, you'll see sliders to adjust the volume, pitch, and duration. Click Apply when you're done. Note that this change will affect only newly launched KDE apps, not ones that are already running.

If you want KDE's system notification feature to produce most beeps
through your sound card, you can still have konsole use the PC
speaker.  To do so, bring up the Settings menu, then look at the Bell
submenu.  One of the options tells konsole to use the PC speaker.  If
you want to make this your konsole default, select 'Save as default'
afterwards.

Dave


Thanks for the reply Dave.

I have actually tried all of the things that you listed plus more to no avail however I just solved the problem by opening Accessibility in Control Center and checking "Use System Bell".

The way I found it to be the cause was going through all the *rc files in ~/.kde/share/config, kaccessrc was the culprit. I guess if you open Accessibility, whether you change anything or not, kaccessrc is created with the defaults "SystemBell=false".

Joshua






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]