[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC2 and ATI 3.9.0



   Has anyone managed to get the ATI 3.9.0 fglrx drivers to
build against the new 2.6.6-1.406smp fedora kernel. I tried 
the following...

1) downloaded and installed fglrx-4.3.0-3.9.0.i386.rpm
2) downloaded http://rambo.its.tudelft.nl/~ewald/patches/fglrx-3.9.0-fc2.patch
and applied it to /lib/modules/fglrx/build_mod
3) downloaded the kernel-sourcecode-2.6.6-1.406 rpm and installed it
4) created symlinks of /usr/src/linux and /usr/src/linux-2.6.6-1.406smp
to /usr/src/linux-2.6.6-1.406.

Now the confusing part. In the past with Linux 2.4 kernels, I have
always just copied the appropriate config from /boot...
config-2.6.6-1.406smp in this case... to /usr/src/linux
and then did...
    cd /usr/src/linux
    make mrproper
    cp config-2.6.6-1.406smp .config
    make oldconfig
    make dep

It seems that 'make dep' is depreciated from Linux 2.6 and I
need to do 'make prepare' instead? However the order in which
I should do this is now unclear. If I replace 'make dep'
with 'make prepare' in the above sequence it seems to not
use the proper .config settings from 'make oldconfig'.
Also I find that /lib/modules/2.6.6-1.406smp has an 
actual build directory in it rather than the expected
symlink back to ../../../usr/src/linux-2.6.6-1.406smp.
What should I do about that? I tried moving it aside
and replacing /lib/modules/2.6.6-1.406smp/build with
a symlink to ../../../usr/src/linux-2.6.6-1.406smp.
However I find that when I go into /lib/modules/fglrx/build_mod
and do 'sh ./make.sh' I get a failed build...

ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.6-1.406smp/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.6-1.406'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/agp3.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/nvidia-agp.o
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `agp_generic_alloc_page':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:1405: error: structure has no member named `count'
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c: In function `ali_alloc_page':
/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.c:4416: error: structure has no member named `count'
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/agpgart_be.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.6-1.406'
make: *** [kmod_build] Error 2
build succeeded with return value 0
ln: `./fglrx.ko': File exists
duplicating results into driver repository...
cp: cannot stat `fglrx.ko': No such file or directory
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================

Anyone else having better luck with this process?
                 Jack



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]