[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: usb storage and FC2



Emiliano Brunetti wrote:
On Thu, 2004-06-03 at 23:40, Alex White wrote:

Emiliano Brunetti wrote:


Hi everybody,

i think it was already asked but i couldn't find something by searching
archives, so here it goes...

I recently upgraded to FC2, and i can't use usb memory sticks. Nothing
happens when i plug the stick in. No usb-storage module loaded,
/var/log/messages says:


Jun 3 16:48:23 brunettie kernel: usb 3-2: new full speed USB device using address 2 Jun 3 16:48:28 brunettie kernel: usb 3-2: control timeout on ep0out Jun 3 16:48:28 brunettie kernel: uhci_hcd 0000:00:1d.2: Unlink after no-IRQ? Different ACPI or APIC settings may help.

I really don't get it. What should i do? Actually it looks like
usb-storage wasn't even compiled as a module...but it looks too strange
to me.

Thanks

Have you tried mounting the device?


mount -t auto /dev/sda1 /mnt


No way. I can't mount something without, at least, having kernel mode
usb-storage properly insmod'ed. And what i was saying a few lines up, is
that apparently usb-storage is missing from my machine - though i
upgraded from FC1 to FC2 by iso images.


Have you also tried mounting using the device /dev/sda. Give either of those a shot, it apparently sees the device since your log says "new device added" so on and so forth.


It says so, but it doesn't load usb-storage into kernel and then it
gives up since it can't find an IRQ for the new device.


Also, try plugging the usb device in and then:

cat /etc/fstab

Does it reveal that a mountpoint was created for the device and an entry in fstab thusly written?


Absolutely nothing happens.

Somebody told me that this thing of memeory stick not being mounted was
something known to happen with FC2. Maybe they were wrong.


My point now is: i don't have usb-storage on my system - is this normal
for a normal FC2 upgrade? How can i do to fix it? Brand new kernel or
just compiling some new modules? As to both chances, a bit of help is
needed. I never compiled a 2.6.


What does


locate usb-storage

or (as root)

modprobe usb-storage

Say?

AFAIK there was a bug with usb storage in 2.6.5. An upgrade of your
kernel might help.

Alex



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]