[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmdb



On Fri, 2004-06-04 at 21:56, jonas2 optimum2 mii lt wrote:
> Hi,
> How fix rpmdb error:
> 
> bash-2.05b$ up2date
> rpmdb: PANIC: fatal region error detected; run recovery
> error: db4 error(-30978) from dbenv->open: DB_RUNRECOVERY: Fatal error, 
> run database recovery
> error: cannot open Packages index using db3 -  (-30978)
> error: cannot open Packages database in /var/lib/rpm
> Traceback (most recent call last):
>    File "/usr/sbin/up2date", line 1271, in ?
>      sys.exit(main() or 0)
>    File "/usr/sbin/up2date", line 680, in main
>      ret = sanityChecks(fromDaemon, hasGui)
>    File "/usr/sbin/up2date", line 295, in sanityChecks
>      if cfg["useGPG"] and gpgUtils.checkGPGInstallation() == 2:
>    File "/usr/share/rhn/up2date_client/gpgUtils.py", line 31, in 
> checkGPGInstallation
>      if not findKey(redhat_gpg_fingerprint):
>    File "/usr/share/rhn/up2date_client/gpgUtils.py", line 75, in findKey
>      return rpmUtils.installedHeadersNameVersion("gpg-pubkey", version)
>    File "/usr/share/rhn/up2date_client/rpmUtils.py", line 102, in 
> installedHeadersNameVersion
>      mi = _ts.dbMatch('Name', pkgName)
> TypeError: rpmdb open failed
> 
> this happened after apt-get upgrade downloads
> by fedora-2 kernel 2.6.6-1
---
try (as root)
rm -fr /var/lib/rpm/*db*
rpm --rebuilddb

Craig



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]