[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

infrared problems [FC2]



hello, and excuse me for posting this again, i just
hope to get this solved.

i am trying to get the irda (infrared) services to
work with my mobile phone, but it does not seemt to
work.

here is what i have done and how some config files
look.

i have fedora core 2, kernel 2.6.5-1.358 (selinux=0).


dmesg |grep -i tty reports
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a NS16550A
the second is the infrared port.

i used setserial the following way:
setserial /dev/ttyS1 port 0x2f8 irq 3

the devices look like:
crw-rw----  1 root root 161, 0 Jun  6 13:11 ircomm0
crw-rw----  1 root uucp 4, 65 Jun  6 13:11 ttyS1

modules.conf
empty


modprobe.conf
# Note: for use under 2.4, changes must also be made
to modules.conf!
alias eth0 e100
alias usb-controller usb-uhci
alias sound-slot-0 snd-cs46xx
alias tty-ldisc-11 irtty
alias char-major-161 ircomm-tty
# alias char-major-161-* ircomm-tty
alias irda-dongle-0 tekram
alias irda-dongle-1 esi
alias irda-dongle-2 actisys
alias irda-dongle-3 actisys
alias irda-dongle-4 girbil
alias irda-dongle-5 litelink
alias irda-dongle-6 airport
alias irda-dongle-7 old_belkin
alias irda-dongle-8 ep7211_ir
alias irda-dongle-9 mcp2120
alias irda-dongle-10 act200l
alias irda-dongle-11 ma600
options nsc-ircc dongle_id=0x09 # NSC driver on a IBM
Thinkpad laptop
alias irda0 nsc-ircc

# IRLAN
# But currently the IrLAN protocol is no longer
maintained
# by the Linux/IrDA core team.
alias irlan0 irlan


install sound-slot-0 /sbin/modprobe --first-time
--ignore-install sound-slot-0 && { /bin/aumix-minimal
-f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f
/etc/.aumixrc -S >/dev/null 2>&1 || :; } ;
/sbin/modprobe -r --first-time --ignore-remove
sound-slot-0






then to have my nokia 6110 mobile phone (with hardware
modem) to speak with the computer i have previously
been able to do:
irattach /dev/ttyS1 -s

and then use the /dev/ircomm0 port for communication.
however now when i run irattach /dev/ttyS1 -s
i get the following in the messages log.

Jun  6 13:31:09 computer irattach: irattach: tty:
set_disc(11): Bad file descriptor 
Jun  6 13:31:09 computer irattach: Stopping device
/dev/ttyS1
Jun  6 13:31:09 computer irattach:
ioctl(SIOCGIFFLAGS): No such device
Jun  6 13:31:09 computer irattach: exiting ... 


i have looked at the descriptions at 
http://www.tldp.org/HOWTO/Infrared-HOWTO/index.html
this has helped before, but this time, nothing.


any help would be appreciated.
kb


	
		
__________________________________
Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger.
http://messenger.yahoo.com/ 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]