[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fc2 install disaster



Thanks to those who responded.

I don't think it was a disk space problem as the partitions were quite big
and the first package to fail was glibc (the 10th package) on the list but
another 500 packages after that succeeded. According to the logs they all
failed during the post-install script, a disk space problem would have made
rpm complain about disk space.

As for hardware, the machine's a totally standard Dell that's been running
various redhats for nearly a year with no problems.

Also, both failed installs seemed to be broken in exactly the same way.

In the end, I abandonned LVM and everything installed fine. 

So it seems that something in the scripts doesn't like LVM.

Is there a way to get rpm to output more detailed failure reports (line
numbers etc)? I'd be willing to reproduce the failed install again if I
thought it might help squish a bug,

F

On Wed, Jun 09, 2004 at 09:57:32AM +0100, Fergal Daly wrote:
> Hi,
> 
> I've just spent quite a while trying to get FC2 installed and in the end had
> to revert to FC1. The install logs show that some packages installed fine
> but others didn't. Doing an "everything" install, the first 1 to fail is
> glibc and the log looks like
> 
> Installing glibc-2.3.2-101.i686.
> error: %post(glibc-2.3.2-101) scriptlet failed, exit status 115
> 
> I ended up with a system with no glibc and no kernel!
> 
> I don't think it's a disk space problem as the log shows lots of other
> packages that do install, however I only had about 400M for / (with /var,
> /usr/ and /home their own partitions) and 100M for /boot, I would have
> thought this was enough...
> 
> I was using LVM, which caused me lots of trouble. In fact I got 2 stack
> traces from Anaconda but I didn't have a floppy to save them on.
> 
> The start of the log file and the kickstart file (install.log.syslog is
> empty) are below. The rest of the log file looks similar. In the end only
> about 500 packages succeeded.
> 
> Anyone any ideas what went wrong?
> 
> F
> 
> # Kickstart file automatically generated by anaconda.
> 
> install
> harddrive --partition=hda3 --dir=
> lang en_US.UTF-8
> langsupport --default en_IE.UTF-8
> keyboard uk
> xconfig --card "ATI Radeon 9800" --videoram 131072 --hsync 31-92 --vsync 50-150 --resolution 1024x768 --depth 24 --startxonboot  --defaultdesktop gnome
> network --device eth0 --bootproto static --ip 172.31.16.213 --netmask 255.255.255.0 --gateway 172.31.16.213 --nameserver 172.31.16.6 --hostname linux.accpac.com
> rootpw --iscrypted $1$cUU8hjLs$OdAdvZ8cAo7MOVQDgRwBx/
> firewall --enabled --port=ssh:tcp --trust=eth0
> selinux --disabled
> authconfig --enableshadow --enablemd5
> timezone --utc Europe/Dublin
> bootloader --location=mbr --append rhgb quiet
> # The following is the partition information you requested
> # Note that any partitions you deleted are not expressed
> # here so unless you clear all partitions first, this is
> # not guaranteed to work
> #clearpart --linux
> #part /boot --fstype ext3 --size=100
> #part pv.2 --noformat --onpart hda2
> #part swap --noformat --onpart hda6
> #part pv.7 --noformat --onpart hda7
> #part / --fstype ext3 --size=8 --grow
> #volgroup Volume00 pv.2 pv.7
> #logvol /usr --fstype ext3 --name=LogVol02 --vgname=Volume00 --size=11484.0
> #logvol /usr/local --fstype ext3 --name=LogVol01 --vgname=Volume00 --size=5000.0
> #logvol /var --fstype ext3 --name=LogVol00 --vgname=Volume00 --size=1000.0
> 
> %packages
> @ everything
> kernel
> e2fsprogs
> grub
> 
> %post
> 
> 
> 
> ----- log file
> 
> Installing 1459 packages
> 
> Installing fedora-logos-1.1.20-1.noarch.
> Installing hwdata-0.101-1.noarch.
> Installing libgcc-3.3.2-1.i386.
> Installing setup-2.5.27-1.1.noarch.
> Installing filesystem-2.2.1-5.i386.
> Installing basesystem-8.0-2.noarch.
> Installing termcap-11.0.1-17.noarch.
> Installing tzdata-2003d-1.noarch.
> Installing glibc-common-2.3.2-101.i386.
> Installing glibc-2.3.2-101.i686.
> error: %post(glibc-2.3.2-101) scriptlet failed, exit status 115
> Installing beecrypt-3.0.1-0.20030630.1.i386.
> Installing bzip2-libs-1.0.2-10.i386.
> Installing chkconfig-1.3.9-1.i386.
> Installing cracklib-2.7-23.i386.
> Installing e2fsprogs-1.34-1.i386.
> Installing elfutils-libelf-0.89-2.i386.
> Installing ethtool-1.8-2.1.i386.
> Installing expat-1.95.5-3.i386.
> Installing gdbm-1.8.0-21.i386.
> Installing glib-1.2.10-11.i386.
> Installing glib2-2.2.3-1.1.i386.
> Installing hdparm-5.4-3.i386.
> Installing iputils-20020927-9.1.i386.
> Installing libattr-2.4.1-2.i386.
> Installing libacl-2.2.7-2.i386.
> Installing libstdc++-3.3.2-1.i386.
> Installing db4-4.1.25-14.i386.
> Installing gmp-4.1.2-9.i386.
> Installing libtermcap-2.0.8-36.i386.
> Installing losetup-2.11y-29.i386.
> Installing mingetty-1.06-2.i386.
> Installing mktemp-1.5.1-1.i386.
> Installing bash-2.05b-31.i386.
> error: %post(bash-2.05b-31) scriptlet failed, exit status 0
> Installing fedora-release-1-3.i386.
> Installing iproute-2.4.7-11.i386.
> Installing lvm-1.0.3-13.i386.
> Installing MAKEDEV-3.3.8-2.i386.
> error: %pre(MAKEDEV-3.3.8-2) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping MAKEDEV-3.3.8-2
> Installing mount-2.11y-29.i386.
> Installing ncurses-5.3-9.i386.
> Installing less-378-11.1.i386.
> Installing net-tools-1.60-20.1.i386.
> Installing pcre-4.4-1.i386.
> Installing popt-1.8.1-0.30.i386.
> Installing psmisc-21.3-2.RHEL.0.i386.
> Installing raidtools-1.00.3-6.i386.
> error: %post(raidtools-1.00.3-6) scriptlet failed, exit status 0
> Installing rootfiles-7.2-6.noarch.
> error: %pre(rootfiles-7.2-6) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping rootfiles-7.2-6
> Installing setserial-2.17-13.i386.
> Installing shadow-utils-4.0.3-12.i386.
> Installing slang-1.4.5-18.1.i386.
> Installing newt-0.51.6-1.i386.
> Installing usbutils-0.11-2.1.i386.
> Installing hotplug-2003_08_05-1.i386.
> Installing words-2-21.noarch.
> Installing cracklib-dicts-2.7-23.i386.
> Installing zlib-1.2.0.7-2.i386.
> Installing file-4.02-2.i386.
> Installing info-4.5-2.i386.
> error: %post(info-4.5-2) scriptlet failed, exit status 0
> Installing cpio-2.5-5.i386.
> error: %post(cpio-2.5-5) scriptlet failed, exit status 0
> Installing diffutils-2.8.1-9.i386.
> error: %post(diffutils-2.8.1-9) scriptlet failed, exit status 0
> Installing ed-0.2-34.i386.
> error: %post(ed-0.2-34) scriptlet failed, exit status 0
> Installing findutils-4.1.7-17.i386.
> error: %post(findutils-4.1.7-17) scriptlet failed, exit status 0
> Installing gawk-3.1.3-3.i386.
> error: %post(gawk-3.1.3-3) scriptlet failed, exit status 0
> Installing gpm-1.20.1-38.i386.
> error: %post(gpm-1.20.1-38) scriptlet failed, exit status 0
> Installing grep-2.5.1-17.i386.
> error: %post(grep-2.5.1-17) scriptlet failed, exit status 0
> Installing coreutils-5.0-24.i386.
> error: %pre(coreutils-5.0-24) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping coreutils-5.0-24
> Installing ash-0.3.8-15.i386.
> error: %post(ash-0.3.8-15) scriptlet failed, exit status 0
> Installing grub-0.93-7.i386.
> error: %post(grub-0.93-7) scriptlet failed, exit status 0
> Installing gzip-1.3.3-11.i386.
> error: %post(gzip-1.3.3-11) scriptlet failed, exit status 0
> Installing krb5-libs-1.3.1-6.i386.
> Installing modutils-2.4.25-13.i386.
> error: %post(modutils-2.4.25-13) scriptlet failed, exit status 0
> Installing openssl-0.9.7a-23.i686.
> Installing procps-2.0.17-1.i386.
> error: %post(procps-2.0.17-1) scriptlet failed, exit status 0
> Installing readline-4.3-7.i386.
> error: %post(readline-4.3-7) scriptlet failed, exit status 0
> Installing python-2.2.3-7.i386.
> Installing pyxf86config-0.3.12-1.i386.
> Installing rhpl-0.121-1.i386.
> Installing rpm-4.2.1-0.30.i386.
> error: %pre(rpm-4.2.1-0.30) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping rpm-4.2.1-0.30
> Installing sed-4.0.8-1.i386.
> error: %post(sed-4.0.8-1) scriptlet failed, exit status 0
> Installing dev-3.3.8-2.i386.
> error: %pre(dev-3.3.8-2) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping dev-3.3.8-2
> Installing pam-0.77-15.i386.
> error: %pre(pam-0.77-15) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping pam-0.77-15
> Installing authconfig-4.3.8-1.i386.
> Installing kudzu-1.1.36-1.i386.
> error: %post(kudzu-1.1.36-1) scriptlet failed, exit status 0
> Installing sysklogd-1.4.1-13.i386.
> error: %post(sysklogd-1.4.1-13) scriptlet failed, exit status 0
> Installing SysVinit-2.85-5.i386.
> error: %post(SysVinit-2.85-5) scriptlet failed, exit status 0
> Installing tar-1.13.25-12.i386.
> error: %post(tar-1.13.25-12) scriptlet failed, exit status 0
> Installing mkinitrd-3.5.14-1.i386.
> Installing util-linux-2.11y-29.i386.
> error: %post(util-linux-2.11y-29) scriptlet failed, exit status 0
> Installing vim-common-6.2.121-1.i386.
> Installing vim-minimal-6.2.121-1.i386.
> Installing which-2.16-1.i386.
> error: %post(which-2.16-1) scriptlet failed, exit status 0
> Installing initscripts-7.42-1.i386.
> error: %pre(initscripts-7.42-1) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping initscripts-7.42-1
> Installing cyrus-sasl-2.1.15-6.i386.
> error: %post(cyrus-sasl-2.1.15-6) scriptlet failed, exit status 0
> Installing cyrus-sasl-md5-2.1.15-6.i386.
> Installing kernel-2.4.22-1.2115.nptl.i686.
> error: %pre(kernel-2.4.22-1.2115.nptl) scriptlet failed, exit status 0
> error:   install: %pre scriptlet failed (2), skipping kernel-2.4.22-1.2115.nptl
> Installing openldap-2.1.22-8.i386.
> Installing libuser-0.51.7-2.i386.
> Installing passwd-0.68-4.i386.
> Installing prelink-0.3.0-13.i386.
> error: %post(prelink-0.3.0-13) scriptlet failed, exit status 0
> Installing usermode-1.69-1.i386.
> Installing kbd-1.08-11.i386.
> Installing redhat-config-mouse-1.1.2-1.noarch.
> Installing mailcap-2.1.14-1.1.noarch.
> Installing man-pages-1.60-4.noarch.
> Installing rmt-0.4b34-1.i386.
> Installing dump-0.4b34-1.i386.
> Installing specspo-9.0.92-1.noarch.
> Installing dos2unix-3.1-16.i386.
> Installing dosfstools-2.8-11.i386.
> Installing eject-2.0.13-3.i386.
> Installing elfutils-0.89-2.i386.
> Installing finger-0.17-18.1.i386.
> Installing hesiod-3.0.2-27.i386.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]