[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ip Routing Through Cluster



Ok all, still have no sound from SB Live! 5.1, but that can wait.

Am successfully bonding two dual PII266 machines via crossover cables to make a workstation out of the hardware I have 'round the house. node1 and node2 on network.com (192.168.2.0) can ping between eachother just fine on each machine's bond0 NIC (192.168.2.1/192.168.2.2 node1/node2). eth0 and eth1 in each machine are SLAVE of bond0 device.

NIC (eth2) in node1 attached to network.net (192.168.1.0) via LinkSys switch uplinked to LinkSys Cable/DSL router. DHCP on router gives node1/eth2 an ip of 192.168.1.100. Forwarding turned on at node1 in sysctl.conf and route on eth2 from 192.168.2.1 (bond0) to 192.168.1.100 (eth2); have tried to go to router (192.168.1.1) as well.

node1 can access internet fine... here now using webmail so can give root information. Here's my ipconfig -a:

bond0     Link encap:Ethernet  HWaddr 00:50:BA:5A:5F:02
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:184 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3964 (3.8 Kb)  TX bytes:13710 (13.3 Kb)
 
eth0      Link encap:Ethernet  HWaddr 00:50:BA:5A:5F:02
          inet6 addr: fe80::250:baff:fe5a:5f02/64 Scope:Link
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:25 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2072 (2.0 Kb)  TX bytes:7174 (7.0 Kb)
          Interrupt:153 Base address:0xe400
 
eth1      Link encap:Ethernet  HWaddr 00:50:BA:5A:5F:02
          inet6 addr: fe80::250:baff:fe5a:5f02/64 Scope:Link
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1892 (1.8 Kb)  TX bytes:6536 (6.3 Kb)
          Interrupt:161 Base address:0xe800
 
eth2      Link encap:Ethernet  HWaddr 00:A0:CC:E7:68:06
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2a0:ccff:fee7:6806/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:572 errors:0 dropped:0 overruns:0 frame:0
          TX packets:646 errors:26 dropped:0 overruns:0 carrier:29
          collisions:0 txqueuelen:1000
          RX bytes:282502 (275.8 Kb)  TX bytes:62779 (61.3 Kb)
          Interrupt:145 Base address:0x7000
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2867 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2867 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3074785 (2.9 Mb)  TX bytes:3074785 (2.9 Mb)
 
sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

What amm I getting wrong here? And, please let me know if ya need more infor.

Thanks in advance for your help,

GregS <><
gswallow cfl rr com




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]