[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fetchmail/Sendmail problem after installing FC2



>>>>> "Alexander" == Alexander Dalloz <alexander dalloz uni-bielefeld de> writes:

    Alexander> Am Mo, den 14.06.2004 schrieb Colin Paul Adams um
    Alexander> 11:11:
    >> After installing (from scratch, apart from /home directory)
    >> FC2, I can no longer receive mails from a particular address. I
    >> used to receive mails from him when I had FC1 installed.
    >> 
    >> The address concerned has an MX record - I can get a listing
    >> with dig -t MX, but if I omit the -t MX record, then I get:
    >> 
    >> Truncated, retrying in TCP mode.
    >> 
    >> and then timed out - not servers could be found.

    Alexander> You name resolution setup is broken. You need to fix
    Alexander> it.

    >> fetchmail/sendmail rejects his emails with:
    >> 
    >> maillog.1:Jun 7 23:53:45 colina sendmail[29693]:
    >> i57MiHN5029693: ruleset=check_mail, arg1=<neal 3dsafety com>,
    >> relay=localhost.localdomain [127.0.0.1], reject=451 4.1.8
    >> Domain of sender address neal 3dsafety com does not resolve

    Alexander> The relay is localhost? Ah, because you get the mail
    Alexander> via fetchmail.

    >> So my questions are:
    >> 
    >> 1) Is there a fix for this?

    Alexander> Yes, you must setup DNS proper. If using bind then
    Alexander> check your bind configuration. If you do not use any
    Alexander> own name server then check the /etc/hosts file,
    Alexander> /etc/resolv.conf and /etc/nsswitch.conf to be proper.

These appear to be OK.

I have bind running on my firewall machine (though since that is
running Redhat 7.2, it may well be an old version (9.1.0-10, in fact).

If I run dig command on that machine, I get the correct answer,
whether I use the -t flag or not.

If I run dig from my main machine, the query without the -t flag (or
with -t A) times out, but the query with -t MX returns instantly, with
the correct answer from the firewall machine.

resolve.conf has a line

nameserver 10.0.1.1, which is the IP address of my firewall
machine. (on the firewall machine, resolv.conf has the line nameserver
127.0.0.1).

So I can't figure out what's wrong. 

Any more clues, please?
-- 
Colin Paul Adams
Preston Lancashire



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]