prelink breaks VMware 4.5.2 on FC2?

Keith G. Robertson-Turner fedora-forums at
Mon Jun 14 20:37:56 UTC 2004

On Mon, 14 Jun 2004 15:02:59 -0500, dsavage wrote:

> I'm having what may be a similar problem trying to run FC2 as a trial
> guest under FC1 running VMWare v4.5.1-7568.

Hmm, I've never used VMWare in that config before (Linux on Linux), in
fact I only ever run Windows guests, since I already have a multitude of
partitions for running test Linux distros natively. Windows has a habit
of assimilating everything it touches (master boot records, bootsectors,
partitions) which is why I always run it in userspace under emulation from
disk images (on the very rare occasions that I run it at all).

> I cannot get the VMware Tools (needed for runlevel 5) to install under
> FC2 at runlevel 3.

Let's see some logs, or a more detailed description. If it is trying (and
failing) to modprobe kernel modules on the guest, then it could be a
number of things, but not likely related to prelink. If the host has been
BØrked by prelink, then you need to unlink the host binaries first, then
exclude them in the prelink.conf (using the script, but remember to add
/usr/lib/vmware that I omitted).

> Do I need to run your script on the FC2 guest (prelink-0.3.2-1)? Or on
> the FC1 host (prelink-0.3.0-13)?

With the caveat that I've never tested this setup, I'll say you probably
don't need to worry about prelink on the guest. Clean up the host, and try
again, and pay attention to the details of the error messages (and logs?).

Maybe your guest's build environment is incomplete (or missing), for
example. I'd really need to see this running first hand.

I'll ask the obvious question, have you tried Googling for "vmware FC2
guest"? Maybe there's a tutorial.

OK, you got me interested. I'll try this here myself. Tomorrow ... need
sleeeeeeeeppppp zzzzzzzzzzz.


(Burning the candle at both ends)

More information about the fedora-list mailing list