[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: prelink breaks VMware 4.5.2 on FC2?



On Mon, 2004-06-14 at 21:39, Keith G. Robertson-Turner wrote:
> Not at all. Simply add "-b /usr/lib/vmware" to prelink.conf, along with
> the rest from the script.

SUCCESS!

Okay. This what I've done. With the aid of your script I added the
following to /etc/prelink.conf:

-b /usr/lib/vmware
-b /usr/bin/vmnet-bridge
-b /usr/bin/vmnet-dhcpd
-b /usr/bin/vmnet-natd
-b /usr/bin/vmnet-netifup
-b /usr/bin/vmnet-sniffer
-b /usr/bin/vmware-loop
-b /usr/bin/vmware-nmbd
-b /usr/bin/vmware-ping
-b /usr/bin/vmware-smbd
-b /usr/bin/vmware-smbpasswd.bin
-b /usr/bin/vmware-vdiskmanager

Then I ran prelink. I wasn't quite sure of what the best incantation for
prelink was so I just did "sudo /etc/cron.daily/prelink" as I figured
that was what had setup prelinking in the first place. It took a *long*
time to run because earlier in the day I had done "prelink -ua". When it
finished I ran vmware and it started just fine. Hooray! Hope this is a
help to others. Although remember it was Keith who did all the hard
work. I'll be appending this fix to my support ticket at VMware.com and
hopefully they might include a post-install script to the next RPM to
make sure the above is present.

Best, Darren

-- 
=====================================================================
D. D. Brierton            darren dzr-web com          www.dzr-web.com
       Trying is the first step towards failure (Homer Simpson)
=====================================================================



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]