[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: AMD64 install fails



On Tue, 2004-06-15 at 07:09, Dr J Austin wrote:
> Hi KAS and List
> 	I have now managed to install FC2
> I tried 6 more times, finally re-partitioning the hard disk
> and having
> sda1 	/boot	100MB
> sda2 	/	75GB
> sda3	swap	3GB
> 
> Did a full install ie ticking every box but NOT the Everything box
> about 4.2GB not 6.7GB
> 
> No boot loader installed on sda
> 
> The POST INSTALL did not fall over but I am sure this is because
> for some reason it no longer has to open /dev/null.
> 
> !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
> The /dev directory is still corrupt !!!!
> !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
> 
> I feel sure there is still a problem with accessing over the end of /dev/ram0
> during install, it is just that some (most) install sequences don't need to use
> the address space that has been corrupted.
> 
> Cheers
> 
> John A
> 
I would try another install making absolutely sure that the installer is
not making any attempt to use hda for anything...particularly taking a
look at advanced boot loader options making sure that it knows that you
want the kernel installed on /dev/sda1.  Make sure that the installer
isn't trying to include swap on /dev/hda to eliminate another possible
point of failure.  Sounds like something is still tripping up
post-install.  I would prolly do an "install everything" to ensure that
nothing vital has been left out.

I wonder if part of the problem is with BIOS reporting the physical
mapping of memory incorrectly...look at the very top of the kernel
startup log for clues...or perhaps APCI is b0rked in that BIOS...have
you tried booting the installer with "noapci" and/or "noapic"
(iirc...syntax may be wrong) and I guess I would check to see if your
BIOS is reasonably up to date.  With a machine that shows any flakiness,
I approach reflashing with a certain amount of trepidation but sometimes
it is the only choice.  I would make sure the system is stone cold
before starting the reflash to make sure that if there are any heat
issues, they are minimized.

KAS




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]