[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

gcc 2.96 on Fedora Core 1



Hello,

I am having troubles compiling the kernel after applying the SCTP patch from www.openss7.org.

I have downloaded a 2.4.22 kernel from kernel.org and I have applied the linux-sctp-0.2.19 patch. Everything went OK. My next steps were:
#make mrproper
#make xconfig
#make dep
#make clean
#make bzImage
This is where I've got the following error:
...
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22/include -Wall -Wstrict-prototypes -Wno-trigra phs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack- boundary=2 -march=athlon -nostdinc -iwithprefix include -DKBUILD_BASENAME=netsyms - DEXPORT_SYMTAB -c netsyms.c
netsyms.c:392: `ipv4_specific' undeclared here (not in a function)
netsyms.c:392: initializer element is not constant
netsyms.c:392: (near initialization for `__ksymtab_ipv4_specific.value')
make[2]: *** [netsyms.o] Error 1
...


I am running Fedora Core 1 and a 3.3.2 gcc compiler (#gcc --version returns “gcc332 (GCC) 3.3.2 20031022 (Red Hat Linux 3.3.2-1)”). I've searched for possible solutions to my problem and found references to problems due to the compiler version. So, I've installed compat-gcc, compat-gcc-g++ and required dependencies (well, in fact I've installed all compat-* rpms, I know it's an overkill, but I just wanted to get read of the problem fast). This gave me gcc and g++ 2.96 and I was hoping that this compiler will solve my problem. But so far I had no luck.

The question is: how do I tell “make” to use gcc 2.96 instead of gcc 3.3.2 ?

This are the things that I have tried:

1.Before compilation I did:
#CC=gcc296
#export CC
#CXX=g++296
#export CXX
Then I followed the normal kernel compilation procedure but this did not helped.


2.I've tried passing CC=gcc296 to make, like “make CC=gcc296 bzImage” instead of “make bzImage”. No luck.

3.This one is inspired from an Oracle Application Server installation on Fedora Core 1. Basically I have renamed gcc and g++ to gcc332 and g++332 and made symbolic links to gcc296 and g++296
#mv /usr/bin/gcc /usr/bin/gcc332
#mv /usr/bin/g++ /usr/bin/g++332
#ln -s /usr/bin/gcc296 /usr/bin/gcc
#ln -s /usr/bin/g++296 /usr/bin/g++
Then a normal kernel compilation. But this does not help either.


I am stuck here and I would appreciate any help, hints or links that would help me solve the problem.

--
Flavius-Ionel I. Copaciu

“There’s no place like 127.0.0.1"

"Research is what I'm doing when I don't know what I'm doing."
= Wernher von Braun =



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]