[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

nfs4 on Fedora Core 2



Hello:
 
I have been trying to use nfs4 on Fedora Core 2. I just installed Fedora Core 2 on my two boxes. On one box I wanted to use as nfs server, I created a directory /pub (and even chmod 777) and export it. The line in /etc/exports reads as "/pub   *(rw,no_root_squash)". I started nfs by "service nfs start" and "rpcinfo -p" showed me that nfs4 are in service. But if I tried from the other box, say by runing "mount -t nfs4 server:/pub /mountpoint", the mount failed and I got an error of
"mount: wrong fs type, bad option, bad superblock on server:/pub,
            or too many mounted file systems."
 
I even tried to clean /var/lib/nfs/rmtab on the server so that "showmount -a server" sees nothing and tried again, I still got that that error.  Should I modify /etc/fstab, /etc/filesystems etc?
 
uname shows "Linux NfsClientBox 2.6.5.1.358 #1 Sat May 8 09:04:50 EDT 2004 i686 athlon i386 GNU/Linux".
 
There is no problem for me to mount the share as nfs version 2 and nfs version 3.
 
Thanks in advance.
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]