[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Java issue



Tom wrote:

I don't know if this is a 2.6 kernel issue, eclipse, or fedora but here goes...
I've got fc 2 installed with eclipse and j2sdk 1.4.2 from sun.  I'm trying to
compile a pretty big project, but I've compiled it before, and its always
worked.  However now with FC 2, it dies about 30 seconds in saying the system
is out of resources.  I open eclipse with vmArgs Xmx768M (which is what I've
always done, and has worked with redhat9, FC1, and Mandrake 9.1 to compile this
project).  In top, as soon as I open eclipse the java process is reported as
taking up 950-980M of RAM.  I don't know if this happened in other settings, I
never looked.  Anyway, although top reports that java is taking 950M of ram in
the process listing, in the summary it reports that only 200M of ram is being
used by the entire system.  Any ideas?




Tom:
Have you tried the beta JDK of 1.5.0? I use eclipse of Fedora 2 (although I admit my projects are small), and I haven't had this problem. It wouldn't hurt to install it and give it a shot. I'm running it on Fedora 2, and it seems to be both faster and more stable, eclipse included.


I actually have both 1.4.2 and 1.5.0 installed, and I modify a 'java.sh' that I keep in /etc/profile.d to point to one or the other. For now I'm sticking with 1.5.0.

Just my 2 cents.

-charlie



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]