[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Java issue



On Fri, 2004-06-18 at 01:21, Tom wrote:
> I don't know if this is a 2.6 kernel issue, eclipse, or fedora but here goes...
> I've got fc 2 installed with eclipse and j2sdk 1.4.2 from sun.  I'm trying to
> compile a pretty big project, but I've compiled it before, and its always
> worked.  However now with FC 2, it dies about 30 seconds in saying the system
> is out of resources.  I open eclipse with vmArgs Xmx768M (which is what I've
> always done, and has worked with redhat9, FC1, and Mandrake 9.1 to compile this
> project).  In top, as soon as I open eclipse the java process is reported as
> taking up 950-980M of RAM.  I don't know if this happened in other settings, I
> never looked.  Anyway, although top reports that java is taking 950M of ram in
> the process listing, in the summary it reports that only 200M of ram is being
> used by the entire system.  Any ideas?
> 

This is a known kernel issue:

http://bugzilla.kernel.org/show_bug.cgi?id=2839

Also see the Fedora issue on this:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121902

Basically there are two things you can do:

a) Either downgrade to the i586 kernel...
b) or upgrade to a bleeding edge kernel (one of Arjans for instance,
although I'm not a 100% certain that the patch that fixes this is in his
kernels)

Regards,
--
Tarjei



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]