[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problems with medium check for FC2 despite of proper checksum! HELP



Hi, 

I have some very weird problems with the core 2 i386 iso files.
I downloaded the files from some ftp mirror. 
My client had a bunch of disconnects when it resumed the download where it
left off afterwards, but at then I had the files. The MD5 checksums for all
4 iso files match the published checksums (checksums published on the mirror
are the same as on the original fedora site, so I assume there is no
difference in what the mirror offers).

I tried burning the images from the ISO files using Nero, which was not a
problem either. The disks are fine, I can read the directory structure
without problems. The machines can boot from the CD and the installation
starts but when I run the medium check of the installer, all four disks
fail. I tried installing them anyway and get an error message when it tries
installing the hwdata-0.118-1.noarch.rpm. The error complains about a
problem possibly caused by a faulty medium, reading problem, etc.
However, if I just copy this file off the CD in windows, upload it to a
linux machine and run an "rpm -qip" on it, it is able to read it. Doesn't
this mean that the RPM should be ok? Or could there be a problem with a part
further towards the end of the file that does not get read to just extract
the info?

I then tried copying my ISO file to another computer to burn it on a
different burner. The burn process fails at about 60-70%. Then  I burned the
1st and 2nd ISO file on a CD just as a file rather than an image in order to
take it to the office and burn it there. The CDs burned fine without
problems again. However, on all the machines in the office I get a CRC error
when I try copying the iso file off the CD onto the harddisk.

Does anybody have any idea what the hell is going on there?

I am not doing this for the first time, I always burn all kinds of CDs with
the same computers and programs. I burned a bunch of copies of FC1 and they
all installed fine.
I remember having media problems after supposedly successful downloads of
FC1, but back then it turned out that the checksums did not match and the
files were too short although the browsers reported the download as
completed. But this time the checksum is ok. The files have the right
length, up to the last byte.

So to summarize this, here are my questions:
1. If the checksums are ok, can I be sure that the iso files were downloaded
ok? I guess it is not *ABSOLUTELY* guaranteed but the likelyhood is *REALLY*
high
2. Could the hwdata RPM be corrupt even though I am able to read the header
info? How can I extract all the files from the RPM without installing them
to really read the RPM all the way to the end?
3. How do I get this to work? Is there anything special I have to consider
when burning the iso images that's different fomr how it worked for FC1?

Thanks,

MARK



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]