[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Boot Issues with FC2

Lonnie Santella wrote:

Can someone please take a shot at this? seems like a fundamental problem, but I've exhausted all my resources. All support docs seem to suggest the same thing, which doesn't work: directories relative to /boot.

Bottom line is, Red Hat 9.0 installs fine on same machine - but FC2 always produces the same problem (below).

Here?s a quick review of my environment:

(1) Always a COMPLETELY clean install ? using Drive Image utility to erase all partitions and restore MBR.

(2) Two machines, both Asus P4 clones with 1 GB RAM, and 1 Western Digital 20 GB hard drive each.

(3) Both machines have subsequently loaded Redhat 9.0 and ran flawlessly ? no problems at all.

(4) I have two different ISO image CD?s from two different mirrors ? both with verified MD5Sum?s and both producing the exact same problem each time.

So I?ve been trying to install FC2 ? I?ve just finished my 11th attempt. Following the advice of different threads and release notes, I always go back to a fresh install before trying anything new.

To minimize variables, I keep the install as simple as possible. I choose ?Automatic Partition?, which creates a 100MB /boot on hda1, a 17GB ?/? (root) on hda2, and a 2GB swap on hda3. I also choose a ?minimal? install to eliminate possible variables from the other CD?s ? this way I only have to use CD1.

Try doing a manual partition. Also verify that the bios is set to lba for these drives and that fdisk shows the correct lba CHS parameters for the drives.

Each time, the install itself is flawless. But after the first reboot ? and naturally each time thereafter, immediately following the POST, I get a black screen with the word ?GRUB? in the upper left corner. No response to keyboard strokes or mouse movement at that point.

I have to rule out hardware ? since this problem with FC2, I have successfully installed and ran RedHat 9.0 and FreeBSD 4.10. I always use a tried and true utility to erase the hard drives of all partitions and restore MBR before installing anything new. This guarantees a pristine physical drive during the install.

I compared the grub.conf files on each machine after the FC2 install. They are identical. No big surprise there I guess. Then, just for further comparison, I isolated one machine and wiped it clean, and loaded RedHat 9.0. Then I compared it?s grub.conf to that of the FC2 install. Almost identical except for the ?/? (root) and swap partitions. In each case the /boot partition is always the first (hda1). In FC2, the ?/? root partition is the second one (hda2) followed but the swap on hda3. But in RedHat 9.0, the swap is on hda2, followed by the / root on hda3. No big deal there, the grub.conf files compensate for this but looking to hda2 on FC2 and hda3 on RedHat 9.0 as one would expect.

Both grub.conf files from FC2 and RedHat 9.0 list an entry as follows:

Root (hd0,0)

? I?m not sure if having different root partitions should affect this or not, but it?s the same in both OS?s.

One other thing I thought was odd is that on both machines, the standard FC2 install puts a strange format or partition table on the physical drive; so much so that it takes a few extreme steps to wipe the partition info off the drive. Normally I would just use the ?delete? function of the utility, which works for all the RedHat dirstros and FreeBSD ? but in FC2 it generates and error stating that it can?t delete the partition. I have to use a utility called ?bigfdisk? then put a dos partition on it, then delete the dos partition ? to get everything set back to a completely empty hard drive.

This is the clue that you may need to check the CHS values and do a manual partiton

I suspect you are seeing the bug related to some mobo/bios and the lba parameters with the 2.6 kernel and partitoning.

My MSI mobo had this problem and after I manually set the CHS parameters on the disk it worked perfectly.

I thought I had the link to the fix for this bookmarked but I can't find it right now.

Maybe someone can repost the link here.

I?d really like to give FC2 a test run ? been looking forward to it. I?ve read the release notes, and browsed for two solid days through news threads and docs. I?m stuck, could you please help me out here?

Thanks in advance,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]