[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: windows-fedora dual boot



Jeff Vian wrote:

On Sat, 2004-06-26 at 10:22, william jones wrote:


In updating to kernal(2.4.22-1.2194.npt1) I was unable to boot Windows
Me which resides on a separate ,removable disk.The message,"no fat file
present",was displayed.Upon booting Fedora 1 ,the 2.4.22-1.2115.npt1
kernal was selected from the grub choice,then shutdown,and the Windows
disk inserted and this time  booted successfully.Going back to the
Fedora disk for a second time the(2.4,22-1.2194.npt1) choice was again
made,booted,shutdown, the Windows disk inserted and booted successfully
this second time.

Why would the upgrade temporarily disable the boot loader,giving the
impression that the situation suggested a Windows XP comparison?
Being completely ignorant of Linux and computer know-how,the situation
could have easily appeared more problematic to a novice like me.Perhaps
it was only because my Windows disk had been partitioned to accept a
Linux distro ,though still unused,that the corruption happened at all.

I thought I should record this event since removable drives are
recommended as an excellent choice for anyone moving to Linux from
Windows and other Windows distros appear not to be immune from kernal
upgrade related problems.It has been my experience that removable drives
are an excellent approach and that Fedora Core 1 is a great choice for
anyone new to Linux;just don't be in a rush to upgrade.

Bill



I have never had your problem with any version of RH, nor with FC1, but
XP is by far not the only version of windows to suffer from this type
problem with FC2.

In my case a 20gb drive, holding a Win98 install was the master drive. FC2 was installed as a clean install on the slave drive (hdb). NOTHING
was supposed to be written to the partition table of hda, but I now have
the following partitions on hda.


In this case, I allowed Disk Druid to manage the partitions of hdb, so I
have to wonder if this may have been aggravated by the tendency of DD to
do its own thing with your drives.


____________________________________________________
[root goliath root]# fdisk -l /dev/hda

Disk /dev/hda: 20.4 GB, 20490559488 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1        2481    19922458+  83  Linux
/dev/hda2   *        1025        2491    11783677+   c  W95 FAT32 (LBA)
___________________________________________________________

Notice that the single fat32 partition that was the only partition
originally on the drive and was a full 20gb in size is now only 12gb and
is the second partition (hda2).  It also is contained entirely within
the first partition (hda1) that was created by installing FC2 on the
second drive

I can boot Win98 with grub as /dev/hda2 and everything seems to work OK,
but I really got bitten by the bug with anaconda on FC2 in  spite of
making all the recommended preparations and taking steps to be sure the
LBA problem did not surface.






Thanks,Jeff,for offering a possible explanation.What prompted me to post was the fact that the example I gave mimicked a more serious problem while the solution which corrected the windows disk error was hardly what one would think of as being credible;I simply retraced steps that I knew worked.
Initially I got the message from my Windows disk "to insert a disk in drive A".After the boot disk produced no solution,I ran fdisk,I believe,and it was there that I was informed that,"No fat file was present".Because I was dealing with removable drives,I knew that the windows drive was not involved in anything major;data would be there still.Having the two drives allows me to have two ways to access information on the net,a plus for me,while helping to separate issues that involve either disk.I'm a true beginner at things Linux and computers.


I'll read up on dd and issues posted in reference and see what I can learn.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]