[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pilot usb settings



Thanks Ben,

My Palm is a Tungsten, so I am doing the following commands separately,

ln -s /dev/ttyUSB1 /dev/pilot

then

chmod 666 /dev/pilot

and then I run the gnome-pilot and try to sync.

Still not seeing the unit, although it did when I ran JDS a while ago, so I will mess around a little more,

Thanks again for the support,

norman

Ben Steeves wrote:
On Sun, 27 Jun 2004 21:32:23 -0400, Greg Swallow <gswallow cfl rr com> wrote:

  
where # is 0, 1, then 2

ln -s /dev/ttyUSB# /dev/pilot (create default /dev for gnome-pilot)

chmod 666 /dev/ttyUSB# (0, 1, and 2)
chmod 666 /dev/pilot (the new /dev)

    

Your instructions are a little unclear -- are you saying you should do
the link (the ln command) for all three files?  'Cos that won't work
-- once the first file is linked to that file name (/dev/pilot), ln
will give you the error message that the file already exists.  The
/dev/pilot link needs to be made *only* to the /dev/ttyUSB? device on
which your particular device passes data (although they all open two
channels, only one is used for data -- the other is (at a guess) for
communication control).

On a Tungsten-line handheld, that port is /dev/ttyUSB1.  On an m5xx,
it's /dev/ttyUSB0.  To figure out which it is for your particular
device, kill off gpilotd, and try the following (after changing the
permissions on the ports as above)...

pilot-xfer -p /dev/ttyUSB{0 or 1} -l

...which will print a list of all the databases on your handheld (if
the connection port was the correct one).  If it just hangs, do a
Ctrl-C and try the other port.

  

--
Norman LeCouvie
Norman LeCouvie
Executive Director - Government Sector
International Americas
Sun Microsystems Inc.

613-787-5229
www.sun.com
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]