[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC2: No Neomagic Sound



The on-board soundcard is detected by System-config-souncard:
Neomagic Corporation
Modell: NM2200 (Magic Media 256AV Audio)
Modul: snd-nm256
which should be correct.

Playing the testsound gives me:
>  amixer: Mixer attach default error: No such device
>  amixer: Mixer attach default error: No such device
>  sox: Can't open output file '/dev/dsp': No such device -8

/dev/dsp exist:
>  [root erle root]# ll /dev/dsp
>  crw-------  1 joerg root 14, 3 23. Feb 22:02 /dev/dsp

/var/log/messages shows:
> Jun 28 17:15:07 erle kernel: nm256: no ac97 is found!
> Jun 28 17:15:07 erle kernel: force the driver to load by passing in the module parameter
> Jun 28 17:15:07 erle kernel: force_ac97=1
> Jun 28 17:15:07 erle kernel: or try sb16 or cs423x drivers instead.
> Jun 28 17:15:07 erle kernel: NeoMagic 256: probe of 0000:01:00.1 failed with error -6


force_ac97=1, sb16, cs423x alltogether doesn't work.

# lsmod
> Module Size Used by
> snd_pcm_oss 41000 0
> snd_mixer_oss 13824 1 snd_pcm_oss
> snd_nm256 65064 0
> snd_ac97_codec 54788 1 snd_nm256
> snd_pcm 69256 2 snd_pcm_oss,snd_nm256
> snd_page_alloc 8072 1 snd_pcm
> snd_timer 17284 1 snd_pcm
> snd 39396 6 snd_pcm_oss,snd_mixer_oss, snd_nm256, snd_ac97_codec, snd_pcm,snd_timer
> soundcore 6112 1 snd


Any help will be appreciated.

Joerg



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]