[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC1 netgear FA311 [kinda solved]





Andy Green wrote:
On Monday 28 June 2004 08:44, John McBride wrote:

I bought one of these cards because it says "Linux" on the box, only to
find it seems to have severe problems...or maybe it's the "natsemi" driver?

In particular it floods the logs and console with "ethX: PCI error
0x800000" whenever I try to bring it up...I saw something on the web
about this being a "parity error".

Do some BIOSes not have the ability to ignore #PERR on PCI? Have a look at your settings.


Thanks for the suggestion. Unfortunately my Bios does not have this setting.

I worked the problem for awhile this morning:

1) yum update to the 2194 kernel.
2) try the RedHat 7.2 source code off the supplied netgear CDROM.
3) try the scyld.com pci-scan.o and natsemi.o modules.

All gave the same or similar errors...usually "PCI error" or "Something Wicked" and then 0x800000 or some similar number.

Then I tried swapping the card into another updated Fedora Core 1 machine. I took it out of the K-6/2 400 mhz I was trying to dual home (with another NIC using the 8139 chip) and swapped it into my athlon 1.2 ghz.

Now the athlon has this "MacPhyter" netgear fa311 board (it's the XXX16 chip) and the old K-6 has two 8139 based NICs, dual homed.

And now everything is working just peachy. Must be something about that K6 mobo and via chipset? Or combining the netgear fa311 with an 8139 in the same box? The mobo is an Epox MVP3C or some such.

I'm just going to leave it this way since everything is working, unless someone wants me to run some more tests.

---
John




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]