[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora Core 2 and audio



Hi,

I'm new to this list; not all that new to Linux though. I recently upgraded from RedHat 8 (Psyche?) to Fedora Core 2. Maybe I expected too much, but when I started up xmms there was no audio from the audio interface - I use headphones plugged into the headphone jack of the audio interface. Xmms worked out of the box on RedHat 8.

I poked around a bit and found that I might need something called ALSA. I found source for 'alsaplayer-0.99.76' compiled and tried to run it. It gives a 'Failed to load output plugin "alsa". Trying defaults.
zsh: segmentation fault alsaplayer' error. I have no idea what an output plugin is, let alone an ALSA one.


I poked around some more and found an RPM that might do the trick called 'alsaplayer-0.99.76-2.1.fc2.fr.i386.rpm' I downloaded that and tried installing it - only to find it had failed some dependency checks:
libid3tag.so.0 is needed by alsaplayer-0.99.76-2.1.fc2.fr
libmad.so.0 is needed by alsaplayer-0.99.76-2.1.fc2.fr
libsndfile.so.1 is needed by alsaplayer-0.99.76-2.1.fc2.fr
libsndfile.so.1(libsndfile.so.1.0) is needed by alsaplayer-0.99.76-2.1.fc2.fr
libxosd.so.2 is needed by alsaplayer-0.99.76-2.1.fc2.fr
I'm lost. I have no idea what these are. If they were so important why weren't they part of the core install?


I then poked around some more and found something called 'alsa-oss-1.0.5' You guessed it - I downloaded and tried to install it to no avail. the ./configure gave up the ghost complaining that - 'checking for libasound headers version >= 0.9.0... not present.
configure: error: Sufficiently new version of libasound not found.' I assume this means I do not have a sufficiently new version of libasound installed. I looked around and downloaded 'alsa-lib-1.0.3a-2.i386.rpm,' compiled for Fedora Core 2, which I proceeded to install. The install told me 'package alsa-lib-1.0.3a-2 is already installed.'


To quote someone else on this list, 'WTF?' How hard is it to get sound working on a Linux machine? Any help would be very much appreciated.

(A very frustrated) Steve Cooke.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]