[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [FC1-64] Problem with shared libs



Frederico --
>
>I'm having this weird issue with Fedora and some packages I need to
>install. I've come to the conclusion that I may have some problem with
>my shared libraries. When trying to install the packages, I get this:
>
>[snip]
>libz.so.1 is needed by psa-courier-imap-add-7.0.3-fc1
>libncurses.so.5 is needed by psa-proftpd-1.2.9-fc1
>libpam.so.0 is needed by psa-proftpd-1.2.9-fc1.build040611.14
>libcrypto.so.4 is needed by psa-qmail-1.03-fc1.build040611.14
>libssl.so.4 is needed by psa-qmail-1.03-fc1.build040611.14
>libz.so.1 is needed by psa-qmail-1.03-fc1.build040611.14
>[/snip]
>
I had a similar problem trying to upgrade from FC2 to a rawhide kernel.  I had 
downloaded a bunch of RPM files using wget and used rpm -F to try to do the 
update.  I assumed that I was either missing updated file or that I had a 
synchronization problems with some files I downloaded newer than others.  For 
example, I am assuming that what is happening is that you have a 
less-than-current version of the psa-whatever packages and they are insisting on 
keeping old versions of libz.so etc. and keeping you from updating to new ones.  
If I understand what cvs is supposed to do, I would have been better off using 
cvs rather than wget.  Hopefully, more knowledgeable people here can expand on 
this or will correct me if I am wrong.

-- Phil

PS  I have had plenty of problems about 32- vs 64-bit libraries in FC2, 
especially with gtk2/gdk/pixbuf but I don't think it is the same thing and it 
merits a separate post.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]