[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

copying large files between filesystems

Hello, this isn't necessarily a Fedora specific question either. It is happening while operating from a Fedora Core II install, and I just subscribed to this mailing list which seems to get a good deal of talented traffic. Please allow me to throw this one out there and I promise to be of assistance with other people's problems in the future. :)

I'm trying to copy a large bzip2 archive that is a little bit larger than 2 Gigs, from a disk with a resierfs filesystem on it, to another disk with ext3 filesystem. I only mention the filesystem types because I think this might be the cause of my problem. Immediately after I made the original bzip2 archive I ran md5sum on the resulting file, and kept a copy of that number. After I copy the file to another filesystem, I can not get the same md5sum. I've tried cp, rsync, scp, and dd and they each seem to come up with different md5sums. The byte count is the same however, but the md5sum is always different, so something however minimal is changing and henceforth throwing off the whole bzip2 archive and rendering it unexstractable. I'm totally stressed because this is a back up of my homedir from before a reinstall. :-/ And I'm worried that the original filesystem that I wrote the backup to (the reiserfs filesystem) was so old that it didn't recognize files greater than 2 Gigs, silently.

If I md5sum the file, still in it's place, it's still good.

Any ideas why I can't get matching md5sums from a file copy between filesystems of different type? Any ideas how to recover from this?

Thanks in advance, anyone, with thoughts,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]