[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Input/output errors on file accesses with Fedora Core 2



Hi

I have two applications that simultaneously analyse a large (~750Mb) file.
One application does a "tail -f" on the file.   The other does a "cat"

When they are both running, after a few seconds, the "cat" process fails
with the following error

cat: <NAME OF MY FILE>: Input/output error

The file is on a NFS mounted server, but the problem occurs no matter
how I do the mounts. I have tried udp, tcp, increasing the number of transmissions
and changing the buffer sizes. I am not sure if NFS is an issue. I have tried copying
the file to a local disk, but then the "cat" is so quick, there isn't enought time for
the error to occur.


I am using the 2.6.6-1.435 kernel; the problem occurs for the SMP and the
uniprocessor flavours.  I am running Fedora Core 2.  The applications work
fine on RedHat 9

Has anyone seen this before, of have any ideas?

TIA

Dave Robson




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]