Urgent help needed with Login problems after installation of FC1

Jeremy Brown jeremy at cadre5.com
Tue May 4 18:10:29 UTC 2004

I'm a little confused by your explanation.  Are you getting prompted for 
a password when you try to su from root to a non-root user?  Something like:

$ su bob
su: incorrect password

Did you set up any sort of alternative authentication mechanism, like LDAP?


Gary Rickert wrote:

>I am at my wits end. This is/ is intended to be a production machine to test
>and package our software, and I must get going.
>The system:
>AMD XP 2800+ Barton
>Asus a7n8x-la Nforce2 mobo 
>Nvidia mx-440 onboard graphics
>512mb PC-2700 
>120gb Western Digital hd 
>Samsung 16x DVD-ROM 
>Cyberdrive 52x CD-R/RW 
>Generic Floppy drive
>6-port Media Card Reader
>Since Gnome looked to be working OK, I went ahead and reinstalled adding the
>database and other packages I will need and I am back to where I was before,
>can't login. I booted single user, tried to su to my user and get su:
>Incorrect password. Changed password and same. Created dummy user, password
>and same. CD /HOME ls -l shows 
>drwx 3 user 500 ...
>drwx 3 user2 user2 ...
>I know ther are folks out there that know this stuff, while I can still call
>it "stuff", and I could sure use an idea of what to do next. 
>I have cleaned up this message history to make it easier to read. Thanks
>Sent: Tuesday, May 04, 2004 9:08 AM
>>From Gnome desktop, I was able to logout user, login root, over and over.
>Tried it from terminal again and same symptom.
>Sent: Tuesday, May 04, 2004 8:28 AM
>Load with Gnome desktop went OK. Am able to boot from floppy. From Gnome
>desktop/terminal, I was able to su to root, su to user, and then got same
>symptom trying to su back to root.
>Sent: Tuesday, May 04, 2004 7:44 AM
>df shows hdb2 as /, hdb1 as /boot, and none as /dev/shm.???
>Sent: Tuesday, May 04, 2004 7:41 AM
>After another minimal install, I was able to add my user and su to it and su
>back to root. By the way, I was unable to boot using the boot floppy.
>Apparently set a password (all authentication tokens updated successfully)
>and change again to my user. However, it did not ask for a password. Was
>able to su to root and user several times. Do get "/bin/bash: /root/
>.bashrc: permission denied" message.
>Sent: Tuesday, May 04, 2004 6:56 AM
>Still fighting, and need some ideas. 
>I did a minimal install and was able to login as root, create and login to
>my user. All looks well. Installed again, adding only X-windows. X did not
>start with boot. Ran startx & to get session. Same story but was unable to
>su - after logging as my user. Started another x session and was able to su
>- from there, however I was not able to su back to root after changing back
>to my user again. Tried in another X and same symptom. Again same. This
>should be a good clue, I would think. It is like it does not read the passwd
>when I return. Have to ctrl c to get out of the passwd entry on the su -.
>Don't know if I tried the su root...user...root in the minimum install, so I
>am going to do that again.
>Sent: Monday, May 03, 2004 2:07 PM
>I solved the dual boot problem. There is a setting for how long the boot
>option display, and it was set to 0. Set it to 10 and it works fine. The
>login problem is still a problem. I have reloaded FC1 once again and I still
>cannot login, root or my user. The passwd and edited shadow files are
>attached in case I am missing something.
>Jeff Vian
>Sent: Monday, May 03, 2004 12:22 PM
>As far as Fedora not allowing user login; I usually use the system tool 
>for user admin from the menu and as long as I create the user account 
>and put in the password for that user they always can log in.
>>>>I installed Fedora, default server on a new slave drive on my HP pavilion
>>>>a320n XP system. When booting after the install, the fedora boot will not
>>>>accept my user or root password. Under "linux single" I can see that the
>>>>user and root accounts exist. I can create a user, and that works OK. I
>>>>cannot login.

More information about the fedora-list mailing list