SMTP-Auth and Postfix

Roger Grosswiler roger at
Fri May 7 12:06:07 UTC 2004

> Am Fr, den 07.05.2004 schrieb Roger Grosswiler um 10:52:
>> Hi,
>> i installed smtp-auth for postfix via saslauthd. it seems to work properly, unfortunately i can only check on a
>> webclient now (squirrelmail). i indicated squirrel to do smtp authentication. what i get is the following error:
> You can check whether SMTP AUTH works using telnet. On how to do so and
> the whole topic with Postfix you can find big help on:
>> May  7 10:25:01 link saslauthd[17730]: do_auth         : auth failure: [user=rogerg] [service=smtp] [realm=]
>> [mech=pam] [reason=PAM auth error]
>> somehow, i think, my password is not delivered...but not sure.. do you have any idea? ah, yeah i do authenticate via
>> mech=PAM
> Setting up saslauthd to use shadow as MECH, will it work then?
> echo "MECH=shadow" > /etc/sysconfig/saslauthd
> service saslauthd restart
>> Thanks for any help!
>> Roger
> Alexander


i've tried this out and changed the mode from pam to shadown in /etc/sysconfig/saslauthd - it works. So, it must be
something wrong with pam in this case...the mentionned link in this mail showed, that the file smtp in /etc/pam.d ist
missing and that you just should copy smtp.postfix to smtp - thats it. i did it - and now it works fine - with pam...

Thanks a lot

More information about the fedora-list mailing list