restoring FC1 to *new* partition from tar archive

Luciano Miguel Ferreira Rocha strange at
Sun May 9 11:07:16 UTC 2004

On Sun, May 09, 2004 at 01:28:46AM -0400, Joe(theWordy)Philbrook wrote:
> > Running without -p and --numeric-owner could cause some problems:
> > -p: preserves permissions. Without this, the permissions of extracted
> >     files will be affected by the value of umask.
> > --numeric-owner: if you had created the tar.gz under FC1 and extracted it
> > under MDK, different values for same users in /etc/passwd could cause
> > problems. As you made the tar and extracted it under FC1, you shouldn't
> > worry about this one.
> I'm hoping you mean that as long as the source and destination
> filesystems have an IDENTICAL /etc/password... I shouldn't worry?

That's right, but only for the --numeric-owner. Without -p, some files may
be created without the proper permissions.

Here's a way to check the permission of files installed in your system:
rpm -qf $(rpm -V --nodeps --nomd5 --noscripts $(rpm -qa) | grep '^.M' |
sed 's/.* //') | sort -u

> Actually I did use mdk to create the tar from an FC1 filesystem. And I
> used mdk to restore it as a complete FC1 filesystem... I'm thinking the
> problems would be if I tried to restore it TO the mdk filesystem. (I hope)

No, only if you tried to restore it _under_ a different system.

Luciano Rocha

More information about the fedora-list mailing list