Mouse (PS/2) not working in FC2

Patrick O. Coffey pcoffey at
Fri May 21 20:23:39 UTC 2004

I had this problem too, I got my PS/2 mouse to work by compiling a
custom kernel. Under device drivers / input device support / mouse
interface I checked "Provide legacy /dev/psaux device" after loading my
custom kernel with that option enabled my mouse worked. HTH

Patrick Coffey

On Fri, 2004-05-21 at 15:40, Sven Schuster wrote:
> On Fri, May 21, 2004 at 08:14:44PM +0100, John Lagrue told us:
> > Dan Stromberg wrote:
> > 
> > >I'm having much the same the problem (FC2 doesn't work, FC1 does), with
> > >a Logitech 3 button mouse (no scroll wheel).  On the back it says
> > >Mouseman Serial-Mouseport.
> > >
> > >I've tried a number of things to get it to work, detailed in redhat
> > >bugzilla .
> > >
> > >If others are having ps/2 mouse problems with fc2 but not fc1, I hope
> > >you'll add a "me too" to this bug # so redhat will be able to make
> > >fixing it a priority.
> > >
> So it seems like I'm not the only one having problems...good :-) so
> there's a chance of the problem getting resolved some time. Like I
> told in my mail earlier this day, the mouse (M$ IntelliMouse PS/2)
> worked fine with FC1, and after upgrading to FC2 it happily jumps
> around on the screen, the buttons don't work properly, bringing it
> down: no real work is possible with X.
> I once had similar problems on my Dell Lattitude C840 Notebook with
> RH 7.3, when I didn't have a mouse near and had to use the touchpad
> I had exactly the same effect. In that case, I ran mouseconfig (or
> what its name was in RH 7.3), chose another mouse type (don't
> remember which, has been some time), restarted X11 and it worked.
> But now with FC2 I can't get it working even after calling
> mouseconfig :-(
> Alright, so I'll now add my 0.02 cents to the bugzilla entry and
> hope that someone knows how to resolve this ;-)
> Sven

More information about the fedora-list mailing list