dual boot : fed1 and fed2 no go

Kevin J. Cummings cummings at kjchome.homeip.net
Tue May 25 21:12:40 UTC 2004

Joe(theWordy)Philbrook wrote:
>>title Fedora Core (2.6.5-1.358)
>>   root (hd1,0)
>>   kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/1 rhgb quiet
>>   initrd /initrd-2.6.5-1.358.img
>>title fedcore
>>   rootnoverify (hd0,0)
>>   chainloader +1
>>When I boot into the old fed core one this is the message :
>> "  Error 13 Invalid or unsupported executable format "
>>The name fedcore as you  can see is the first primary disk and fed 2 is on the
>>second. I know I should be reading the forty-five page doc on my desk but I
>>would feel better disposed to grub if I could get out of this quick.My first
>>disk is full of work material.  I have already tried the LBA bios change on
>>the mail list but  no joy. Thanks a lot John Brennan-Sardou
> Well John, I can't say I've read all "forty-five page"s of the doc,
> (didn't count them either) But when I let grub install itself for FC2
> I told it to add entries for each of my linux. And they all looked like
> your fedcore entry... And ALL of them got that error... I also noticed
> that the rootnoverify & chainloader lines were used for the non linux
> win98 partition (which worked for win98) And that convinced me to
> quickly scan "info grub" for a few clues, then used the working FC2
> entry as a guide to rebuild the other linux entries with some help from
> my old lilo.conf for details like kernel names and clues what to append
> to the kernel for it... After which the only thing I still can't boot
> with grub is my DrDos hdc1 partition...<sigh>

 From my reading of the grub info file, the following should boot your 
DrDos partition, provided that:

1) your DrDos boot loader is still in the /dev/hdc boot sector
2) DrDos can boot from the 3rd hard drive (MS-Dos systems were notorious 
for requiring the boot drive to be their "C:" drive)....

title DRDOS
   rootnoverify (hd2, 0)
   chainloader +1

Good luck!  You might have to swap hda,hdb with hdc,hdd in order for 
DrDos to be bootable again.  But, there should be no problem booting 
Linux from the second controller.  Grub should be able to handle that 
OK....  I'm currently booting my system from /dev/hdb2, but grub is 
installed in /dev/hda.

Kevin J. Cummings
kjchome at rcn.com
cummings at kjchome.homeip.net
cummings at kjc386.framingham.ma.us

More information about the fedora-list mailing list