FC2--can't get SMB share from nautilus

Don Campbell donaldtcampbell at charter.net
Thu May 27 05:12:27 UTC 2004

Gerald Thompson wrote:

> Don Campbell wrote:
>> I've exhausted my resources. I've read tfm till I'm dizzy.
>> I've played with swat.
>> I can use smbclient to get information from a WinNT
>> system with shares via "smbclient -L boxname"
>> Samba seems to be working. Nautilus gives me:
>> "The folder contents could not be displayed" Does it
>> ask for a user name and password? NO. Why not?
>> I'm sure that with no proper user name and no password
>> it's perfectly justified in denying me access. Heck, I
>> want it to deny access without those. So what's the
>> secret?
>> As they say over and over in the FC2 list: This didn't
>> happen before I installed FC2. (I was using RH9 before.)
>> What's the magic potion -- secret incantation --whatever
>> that will take away the memory of hours spent futzing
>> around with this problem?
>> TIA
>> Don
> Hi Don;
Thanks for answering.

> First off check the firewall, if the firewall is on then Samba is 
> blocked.
Firewall off, firewall on--no difference. My firewall 
(firestarter--great stuff)
is set to trust the IP of the Samba server I'm trying to connect to and 
it's also
set to have netbios open for that server's IP. Regardless, the behavior is
identical with the firewall off entirely.

> You may have to go into Samba config and allow your user account to 
> use Samba.
Too terse. I have set up a user configuration for Samba but that appears 
to be
mostly to allow others to connect to the linux box and access my shares. It
doesn't seem related to connecting to another box. Regardless, it isn't 
Definitely not working like it was under RH 9.

> Make sure the SMB client is running, SMB server only needs to run if 
> you plan to share out from your Linux box to your NT box.
"Make sure the SMB client is running"  OK--just how does one do that? 
Where is
that documented? Almost 99.99% of the documentation is about serving shares
and not about being a client. I haven't found anything specific about 
being the
client. However, did you read my comment about using smbclient to access
the server? I was able to give it a username and password and get 
from the server. My whole point is that nautilus isn't asking for a 
username or
a password. No wonder it won't let me in. How, pray tell, do I get it to 
do this?
It always did for nautilus running under RH9.

> In your SMB config you have to set up the username and pw that is 
> required to access the SMB share on the other computer.  I only know 
> the gui tool and I know that you have to go into your user account 
> profile and set up the username and pw that you broadcast out when you 
> try to access SMB shares on other computers.

I used the Fedora samba-config tool. I set up a user and a password. No 

>   Your SMB client username and pw to an NT share could be userid guest 
> and pw whatever you set., username may be different if you set up 
> specific usernames on the NT computer.
> In Nautilus try typing in the IP address of  the computer you are 
> sharing to,  and the share name you are trying to access.

I get to the box using the name used in lmhosts. It just doesn't ask for 
a username or a
password. It just says I'm not getting in. It's there. I know it's there 
because it shows
up in nautilus. It's just inaccessible.

> example \\\share
OK, just tried it. Nautilus doesn't like that syntax.

> sometimes if you put the exact share location in that you are after it 
> will cause the username and pw popup and you can log in.

> The big one is the firewall, make sure that the firewall is off, or 
> configured to allow SMB to pass in both directions.

As I said. The firewall is configured EXACTLY the way it was for RH 9 
and whether
it is turned off or turned on makes no difference.

> - either turn the firewall off (if you are behind a router),
> - or open the ports for SMB on the firewall,

As I said. The firewall is set to "trust" totally the IP of the samba 
server. It's set to allow
netbios from that server. And it behaves the same off or on.

> - or allow the IP's of the other computers on your internal network to 
> pass through the firewall.
> To give you any more assistance you should document the things that 
> you have already tried so we can give you suggestions.

Set workgroup to the same workgroup. Entered the name & IP of the server 
to lmhosts and hosts.
Confirmed that executing smbclient -L servername functions fine--it 
queries for the password
and accepts the password that was set for the same user as the linux 
user (although I am
confident that I should be able to have different user names on the 
linux client and on the
samba server).

Basically, it connects except through nautilus I think.

I hope I was clear. Thanks for your help and for any suggestions you can 
 From what my googling is showing I think I'm not alone in having trouble
with FC2 and samba.


> Gerald Thompson
> geraldt at telus.net

More information about the fedora-list mailing list