[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Urgent help needed with Login problems after installation of FC1



Gary Rickert wrote:
I am at my wits end. This is/ is intended to be a production machine to test
and package our software, and I must get going.
The system:
AMD XP 2800+ Barton
Asus a7n8x-la Nforce2 mobo Nvidia mx-440 onboard graphics 512mb PC-2700 120gb Western Digital hd Samsung 16x DVD-ROM Cyberdrive 52x CD-R/RW Generic Floppy drive
6-port Media Card Reader

Since Gnome looked to be working OK, I went ahead and reinstalled adding the
database and other packages I will need and I am back to where I was before,
can't login. I booted single user, tried to su to my user and get su:
Incorrect password. Changed password and same. Created dummy user, password
and same. CD /HOME ls -l shows drwx 3 user 500 ...
drwx 3 user2 user2 ...
I know ther are folks out there that know this stuff, while I can still call
it "stuff", and I could sure use an idea of what to do next.
I have cleaned up this message history to make it easier to read. Thanks
------------------------------------------------------------------------

Sent: Tuesday, May 04, 2004 9:08 AM

From Gnome desktop, I was able to logout user, login root, over and over.
Tried it from terminal again and same symptom.

Sent: Tuesday, May 04, 2004 8:28 AM

Load with Gnome desktop went OK. Am able to boot from floppy. From Gnome
desktop/terminal, I was able to su to root, su to user, and then got same
symptom trying to su back to root.

Sent: Tuesday, May 04, 2004 7:44 AM

df shows hdb2 as /, hdb1 as /boot, and none as /dev/shm.???

Sent: Tuesday, May 04, 2004 7:41 AM

After another minimal install, I was able to add my user and su to it and su
back to root. By the way, I was unable to boot using the boot floppy.
Apparently set a password (all authentication tokens updated successfully)
and change again to my user. However, it did not ask for a password. Was
able to su to root and user several times. Do get "/bin/bash: /root/
.bashrc: permission denied" message.

This is normal for a user that is in the /root/ home directory. The user won't have permission to read the files in the /root/ directory.

If you su to a user from root, there is no requirement for a password. Root has access to everything.


Sent: Tuesday, May 04, 2004 6:56 AM

Still fighting, and need some ideas. I did a minimal install and was able to login as root, create and login to
my user. All looks well. Installed again, adding only X-windows. X did not
                           ^^^^^^^^^^^^^^^
I seem confused about what you are doing. I keep seeing that to "Iinstalled again". If I read this correctly is you are installing a basic system and then starting the installation again to add more components. Am I correct on this point? I don't know if a re-install will clean up/erase the password files that may have been set in a previous install without a disk format.

If this is the case, there is no reason to start an installation again. You can use rpm to install the individual packages that you want from the CD's. I don't know if it is possible to configure yum to work with a CD drive for dependency checks.

If you have gnome running there is also the Package manager under the gnome menu/system settings/add remove applications.

Remove the users and then re-create them or just reset the passwords and see if that works.

I am also wondering if during all the 'su' commands you are getting into $PATH problems. There is 'su' and 'su -' and they both work differently. I know that I made a major screwup the first time I used 'su -', I deleted my /root/* directory by accident.

--
Robin Laing




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]