[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Strange behaviour of mounted USB hd



What suprises me the most, is the fact, that everything worked fine, before I 
attached this hd to a Win xp box.
I was able to read/write with no problem at all.
But after attaching it to the Win box and copying some stuff onto the drive, 
this strange behaviour started.

Btw: I booted knoppix just for test purpose: The drive works fine there :-)
So, I suppose it's a FC1 issue.

bit

Am Mittwoch 05 Mai 2004 07:31 schrieb Satish Balay:
> I think the USB stuff in the FC1 kernel is buggy. I've had issues with
> 2 different external usb enclosures. I guess I should bugzilla
> this. There are currently quiet a few usb issues in bugzilla already -
> without updates. I've had problems with both usb-2 & usb-1 (perhaps
> issues with usb-storage?)
>
> I'm hoping FC2 would have these issues resolved (I have bugzilla entry
> for this one - as I could provide some logs on the bad behavior )
>
> Summary of problems I've encountered:
>
> - bytecc usb-2 enclosure with dvd drive - can't read data after a while
> - iogear ion usb-2 enclosure with hdd
>    - I've had kernel freeze a couple of times
>     a: insertion of the device after suspend/resume (usb-2)
>     b: used usb-1 driver for a while - then suspend resume - kenrel freeze.
>    - I've had iozone benchmark just hang after a while - writing to
>    the usb drive (this is after reboot - before any suspend/resume
>    operation)
>
> This is also with kernel 2.4.22-2188
>
> Satish
>
> On Wed, 5 May 2004, bit wrote:
> > Second Add-on:
> >
> > Sorry, I forgot to mention, which external USB thingie I bought:
> > http://www.mapower.com.tw/map-h31.htm
> > It has a GENESYS 711/811 chipset.
> >
> > Am Mittwoch 05 Mai 2004 01:21 schrieb bit:
> > > Add on:
> > > I _was_ able to read/write, when copying files from my linux box to the
> > > hd earlier today. I just tried to copy the files from the hd, that were
> > > copied onto it from the WinXP box, and that doesn't work.
> > > It starts and only copies about 30 - 40 kb and then hangs as well.
> > > Afterwards, the files disappear again.
> > > And not only the files copied from WinXp disappear (like stated
> > > earlier) but also files, that I copied from my linux box.
> > >
> > > btw: I'm running 2.4.22-2188
> > >
> > > bit
> > >
> > > Am Mittwoch 05 Mai 2004 00:50 schrieb bit:
> > > > Hi,
> > > >
> > > > i bought an external USB 2.0 harddrive frame today, which I equipped
> > > > with an IBM DTLA 30 GB harddrive I had lying around.
> > > > I can mount that drive via my USB 2.0 port - no problem so far.
> > > > I can read/write as normal user, since I specified that in /etc/fstab
> > > > "/dev/sda1        /mnt/USB       vfat    uid=xxx,gid=xxx,rw    0 0"
> > > > Transfer rates are like I expected them to be.
> > > >
> > > > The problem starts, when I do anything else, then just writing to the
> > > > drive or copying from it. For example, trying to watch an mpeg, which
> > > > was copied onto the drive from a Win XP box.
> > > > Xine/mplayer simply refuse to start and hang.
> > > > After that, the files, that were copied from the Win XP box disapear.
> > > > If I then umount the drive and try to remount it, it's not possible
> > > > to do so:
> > > >
> > > > $ mount /dev/sda1 /mnt/USB
> > > > Error: no blockoriented device
> > > >
> > > > $ mount -o loop /dev/sda1 /mnt/USB (-o shouldn't be necessary)
> > > > Error: no device found
> > > >
> > > > I tried looking for a way to restart hotplug, but I couldn't find
> > > > anything in /etc/init.d/
> > > >
> > > > So here are my questions:
> > > > 1. Is there anything special about files, that are written by Win XP
> > > > onto a FAT32 partition ?
> > > >
> > > > 2. Is there a quick way to restart hotplug, and would that help at
> > > > all ?
> > > >
> > > > Or is the hd the one to blame ?
> > > >
> > > > I searched the list archive for "usb mount", but couldn't find
> > > > anything similar.
> > > >
> > > > Thanks for any help or hints.
> > > >
> > > > bit




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]