[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm upgrades segfaulting FC1



On Wed, May 05, 2004 at 08:29:21AM -0500, Brian Hankins wrote:
> Panu Matilainen wrote:
> >On Tue, 4 May 2004, Brian Hankins wrote:
> >
> > 
> >
> >>I am having some trouble with rpm upgrades, while installing new 
> >>packages works fine. This is what I see when running this:
> >># rpm -Uvh package.rpm
> >>Segfault
....
> Thanks for everyone's advice so far. I am not ready to try the rescue CD 

Do you have a reference system to compare and contrast?
If so you can check each file involved by moving a copy
from the problem box to the reference box and checking.

Also try "strace -f -o /tmp/strace-rpm rpm -Uvh package.rpm"

In /tmp/strace-rpm you will see all the libs that it works with.  and
when it breaks.  Perhaps a library link is broken.  Also you can run
in the debugger... gdb...

Anyhow compare and contrast with a healthy box,  it may be obvious
what is wrong when you do.


-- 
	T o m  M i t c h e l l 
	/dev/null the ultimate in secure storage.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]