[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: qtparted rpmbuild problem



On Wed, 05 May 2004 21:51:45 +0200
Alexander Dalloz <alexander dalloz uni-bielefeld de> wrote:

> Am Mi, den 05.05.2004 schrieb John Thompson um 20:39:
> 
> > I'm attempting to build a binary rpm from the qtparted-0.4.4
> > sources.  A .spec file is included in the tarball, so I used
> > "rpmbuild -ba /usr/src/SPECS/qtparted.spec" to build the package. 
> > It appears to compile properly, but fails during the rpm packaging:
> 
> Where did you take the .spec file from?

The tarball from http://qtparted.sourceforge.net includes
qtparted-x11.spec.in, which is used to generate a .spec file during the
configure process.
 
> > RPM build errors:
> >     File not found:
> >     /var/tmp/qtparted-root/usr/share/man/man1/qtparted.1
> > 
> > Sure enough, /var/tmp/qtparted-root/usr/share/man/man1/qtparted.1
> > does not exist, but
> > /var/tmp/qtparted-root/usr/share/man/man1/qtparted.1.gz does exist. 
> > How the blazes can I edit the .spec file to include qtparted.1.gz
> > instead of qtparted.1?  I see no reference to either in the .spec
> > file, but AFAICT the failure occurs somewhere in the %install
> > section:
> >                              
> > %files -f ../file.list.%{name}
 
> Check this %files section.

That's the complete %files section:

  %files -f ../file.list.%{name}
                                                                        
       
  %changelog


I assume something needs to be added in there?


-- 

-John (john os2 dhs org)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]