[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenOffice 1.1.1




On Fri, 7 May 2004, Robin Laing wrote:

> Satish Balay wrote:
> > 
> >>Robin Laing wrote:
> >>
> >>>I have searched all the usual sites but I cannot find a copy of 
> >>>OpenOffice.org 1.1.1.
> > 
> > How about grabbing the .src.rpm file from  1.92/rawhide - and rebuilding on FC1?
> 
> As I asked what is 1.92?

1.92 is FedoroCore2 Test3 snapshot (FC2T3).
> 
> This is an option.  I have never done this but I am willing to learn.

You'll need plenty of disk space - and more than a few hours time (OO
is pretty big). Some instructions are at: (more than what I would do)

http://fedoranews.org/tchung/rpmbuild/
http://fedoranews.org/hoyt/rpm/

Quick summary:

## Create a build setup in your home dir.
cd ~
cp -a /usr/src/redhat/ rpmbuild
echo '%_topdir %(echo $HOME)/rpmbuild' >> .rpmmacros
echo '%debug_package %{nil}' >> .rpmmacros

## Download the src rpm, and try building:
wget ftp://mirrors.kernel.org/fedora/core/development/SRPMS/openoffice.org-1.1.1-4.src.rpm
rpmbuild --rebuild openoffice.org-1.1.1-4.src.rpm

## You'll mostlikely get 'errors of required packages. Install them (as root and retry)
sudo yum install packages
rpmbuild --rebuild openoffice.org-1.1.1-4.src.rpm

-----

## One of the dependent packages is not part of FC1 - so I would
## rebuild this from src.rpm from rawhide as well - and install it
## (before trying to rebuild openoffice.org-1.1.1-4.src.rpm)

wget ftp://mirrors.kernel.org/fedora/core/development/SRPMS/libgnomecups-0.1.6-7.src.rpm
rpmbuild --rebuild libgnomecups-0.1.6-7.src.rpm
cd ~/rpmbuild/RPMS/i386
sudo rpm -Uvh libgnomecups-0.1.6-7.i386.rpm libgnomecups-devel-0.1.6-7.i386.rpm

Whenever you get errors on missing (devel) package - keep installing
them using yum (as root).

Satish



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]