[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Core 1 hangs on booting at Freeing unused kernel memory



On Sat, 2004-05-08 at 02:50, David Woakes wrote:

>> I have Core 1 working quite happily on a Via Epia-M 10000 Nemehiah
>> motherboard and I intend to replace the system with one based on
a Via
>> Epia-M 6000 Motherboard.
>>
>> I have transferred the memory from the original PC and the hard
drive.
>> After changing to an i586 kernel it boots and gets as far as the
>> "Freeing unused kernel memory: 124k freed" and then the system
hangs.


>I have some Epia 5000 Eden (fanless) series boards here and
they've all
>come up as i686 kernels during the install. (I haven't checked,
but I'm
>assuming the 6k series is newer and should be i686 as well)

>I don't know for sure, but that might be the problem.

>Ron

I tried booting with the kernel installed for the Neremiah board, but
that just rebooted immediately with no traces (I'm pretty sure it
was an
i686 kernel).

I've put some traces in linuxrc (in the initrd image) and i know that
script is finishing.  I believe the next step is init should be called.

I'm rather curious about the lack of messages in /var/log/messages, I
thought there should be some...


Going through dmesg here on the boards I've got (not the same as yours,
so there may be differences, but this part of the boot process should be
pretty universal), I get this...

Freeing initrd memory: 158k freed
VFS: Mounted root (ext2 filesystem).
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 120k freed
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 08:32:07 Dec  1 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 5
usb-uhci.c: Detected 2 ports

Perhaps its the usb subsystem that's not being initialized quite right?
Try turning it off in the bios if it's not required for what you're
doing.  That may help in troubleshooting the problem.

You may want to look at /var/log/boot.log and dmesg to try to figure out
what's happening (or not happening as the case may be).

I know I've found a couple oddities with these boards (some of the
hardware is just that little tiny bit off of standard which made for
some head scratching), but for the most part, they work quite nicely and
as advertised.

Ron

------------------

No joy, there are no options to disable USB and as I pointed out before
nothing is written to the logs (boot.log or messages) during any of the
boots.

I added some traces to rc.sysinit, none of these appear.

I agree that given the location of the hang then USB seems to be the
error...

I was able to boot up the Fedora CDs and run through the upgrade process
on the new motherboard, but it still doesn't get past the same message.

I'll try building a kernel with no usb support and see how I get on with
that.

----------------

I've tried a kernel with no usb support and it still hangs at the same message. Any ideas where else i can put tracing to find out what is blocking ?

David
--
t 0131 447 0509
m 07966 444 615
f 07970 205 091
e david mitredata co uk




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]