[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

setting up autofs



This is a DDWID - Don't Do What I Did - post.

I am in the process of splitting my box into two since the drives were
physically overflowing the case. Got the 2nd box put together fine and
decided to start moving things over. Since I still wanted access to the
moved drives, I figured it was time to investigate and setup autofs for
mounting the remote drives.

After an hour of google searches and manpage perusals, it was time to start
configuring everything. I thought I had grokked it all OK and wrote the
/etc/auto.master file with the following entry:

/home/jb/birds	auto.birds	--timeout=10

Stop laughing now, people. I fired it up in X on the destination box and
watched as my Gnome panel disappeared as soon as I clicked on it. WTF???
Had to CTRL-ALT-BS to get to console and kill X. That's when I noticed that
my normal prompt was replaced by the stock bash prompt. Hmmmmm. Visions of
losing my home drive wafted in front of my eyes. Checked my backup drive
and all fine so I wasn't worried much.

Did a quick "mount" and sure enough, the remote directory was mounted OVER my
/home/jb directory. My destination box no longer had a working home
directory.

The moral of the story is that automount takes over the root of the
directory you want mounted. So that is why they give you /misc to play
around with. The solution was to rewrite the auto.master as:

/misc	auto.misc	--timeout=10

and the auto.misc as:

birds   -fstype=nfs,rw,rsize=8192,wsize=8192,no_root_squash,intr
monique:/home/jb4/birds

Then I just  did "ln -s /misc/birds /home/jb/birds" and I was away to the
races. Hope this gives somebody a chuckle or two for the day.

-- 
Jack Bowling
mailto: jbinpg shaw ca



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]