[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Installing FC1 to SATA HDD and VIA VT8237



On Monday 10 May 2004 07:34, Radek Zavicak wrote:
> Hi,
> 
> I have problem to install Fedora Core 1 to a SATA hard disk connected to the
> VIA VT8237 SATA controller on the ASUS A7V600 motherboard (VIA KT600
> chipset). The Fedora installer cannot see the SATA disk. I searched this
> mailing list and found a link to Mike Insch's mini-HOWTO
> http://fedoranews.org/contributors/mike_insch/sata/. I created the driver
> diskette as described in the howto (the only difference was that I used the
> same PC with FC1 installation on a temporary connected ATA IDE disk). When
> I attempt to install Fedora onto a SATA only system and use the driver
> diskette I am not able to succesfully load the driver. Switching to the VC3
> terminal (CTRL+ALT+F3) I can see the messages about unresolved symbols:

I think need to wait for FC2, it will suerly work or try FC2T3 (for me work with my VT8237
i686/x86_64)

 
> ...
> *module viamraid found on driver disk 1
> *loaded viamraid from /tmp/ramfs/DD-0/modules.cgz
> /tmp/viamraid.o: unresolved symbol scsi_unregister_Rd039d977
> /tmp/viamraid.o: unresolved symbol scsi_register_Rc1833384
> /tmp/viamraid.o:
> Hint: You are trying to load module without a GPL compatible license
>       and it has unresolved symbols. Contact the module supplier for
>       assistence, only they can help you.
> *failed to insert /tmp/viamraid.o
> 
> I continued to work around this problem as described in Section 6 of Mike's
> HOWTO and I wanted to correct the hex digits after scsi_registerR and
> scsi_unregister_R strings in viamraid.o-2.4.22-1.2115.nptl. But unlike Mike
> I have nothing to correct, the hex digits are same as those I could see in
> the VC3 terminal. I think that it is because I created the driver on the
> same PC as the PC I am installing to. Mike used different donor PC.
> 
> Does anybody know how to succesfully load the viamraid driver?
> Does anybody have a working viamraid driver diskette for FC1?
> 
> Thanks for any advice
> 
> Radek Zavicak
> 
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]