[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

gdm doesn't start: There is another X server running?



<x-tad-bigger>Hi there:

I have been struggling for days now trying to fix this. It started in a RH9 system after running up2date last week to upgrade the kernel. Once I rebooted (runlevel 5) the GUI login window stop showing up and instead I get a blue window informing me that: "There already appears to be an X server running on display :0. Should I try another display number? ". I eventually get thrown to a terminal where I can login and run "startx" with no problem. I get the same behavior if try to start gdm manually.
I took the opportunity to upgrade to fedora core1 hoping to fix my problem but after running yum yesterday to upgrade the whole system I still get the same problem. I have turned "Debug" on in gdm.conf and this is the part of the logs in /varr/log/messages concerning gdm:
******Start quote*******
May 11 10:43:33 yee gdm[9294]: gdm_main: Here we go...
May 11 10:43:33 yee gdm[9294]: gdm_start_first_unborn_local: Starting :0
May 11 10:43:33 yee gdm[9294]: gdm_display_manage: Managing :0
May 11 10:43:33 yee gdm[9294]: loop check: last_start 0, last_loop 0, now: 1084290213, retry_count: 0
May 11 10:43:33 yee gdm[9294]: Resetting counts for loop of death detection
May 11 10:43:33 yee gdm[9294]: gdm_display_manage: Forked slave: 9295
May 11 10:43:33 yee gdm[9295]: gdm_slave_start: Starting slave process for :0
May 11 10:43:33 yee gdm[9295]: gdm_slave_start: Loop Thingie
May 11 10:43:33 yee gdm[9295]: Sending VT_NUM == -1 for slave 9295
May 11 10:43:33 yee gdm[9295]: Sending VT_NUM 9295 -1
May 11 10:43:33 yee gdm[9294]: Handling message: 'VT_NUM 9295 -1'
May 11 10:43:33 yee gdm[9294]: Got VT_NUM == -1
May 11 10:43:33 yee gdm[9295]: gdm_server_start: :0
May 11 10:43:33 yee gdm[9295]: gdm_auth_secure_display: Setting up access for :0
May 11 10:43:33 yee gdm[9294]: (child 9295) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:33 yee gdm[9295]: gdm_auth_secure_display: Setting up access
May 11 10:43:33 yee gdm[9295]: gdm_auth_secure_display: Setting up access for :0 - 1 entries
May 11 10:43:33 yee gdm[9295]: Sending COOKIE == <secret> for slave 9295
May 11 10:43:33 yee gdm[9295]: Sending COOKIE 9295 ae...
May 11 10:43:33 yee gdm[9294]: Handling message: 'COOKIE 9295 ae...'
May 11 10:43:33 yee gdm[9294]: Got COOKIE == <secret>
May 11 10:43:33 yee gdm[9295]: gdm_server_spawn: Forked server on pid 9296
May 11 10:43:33 yee gdm[9294]: (child 9295) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:33 yee gdm[9295]: do_server_wait: Before mainloop waiting for server
May 11 10:43:33 yee gdm[9296]: gdm_server_spawn: '/usr/X11R6/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7'
May 11 10:43:34 yee gdm[9295]: gdm_server_start: After mainloop waiting for server
May 11 10:43:34 yee gdm[9294]: (child 9295) gdm_server_usr1_handler: Got SIGUSR1, server running
May 11 10:43:34 yee gdm[9295]: gdm_server_start: Completed :0!
May 11 10:43:34 yee gdm[9295]: Sending VT_NUM == 7 for slave 9295
May 11 10:43:34 yee gdm[9295]: Sending VT_NUM 9295 7
May 11 10:43:34 yee gdm[9294]: Handling message: 'VT_NUM 9295 7'
May 11 10:43:34 yee gdm[9294]: Got VT_NUM == 7
May 11 10:43:34 yee gdm[9295]: Sending XPID == 9296 for slave 9295
May 11 10:43:34 yee gdm[9294]: (child 9295) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:34 yee gdm[9295]: Sending XPID 9295 9296
May 11 10:43:34 yee gdm[9294]: Handling message: 'XPID 9295 9296'
May 11 10:43:34 yee gdm[9294]: Got XPID == 9296
May 11 10:43:34 yee gdm[9295]: gdm_slave_run: Opening display :0
May 11 10:43:34 yee gdm[9294]: (child 9295) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:39 yee gdm[9295]: Sending START_NEXT_LOCAL
May 11 10:43:39 yee gdm[9294]: mainloop_sig_callback: Got signal 17
May 11 10:43:39 yee gdm[9294]: gdm_cleanup_children: child 9295 returned 127
May 11 10:43:39 yee gdm[9294]: gdm_child_action: In remanage
May 11 10:43:39 yee gdm[9294]: gdm_display_manage: Managing :0
May 11 10:43:39 yee gdm[9294]: loop check: last_start 1084290213, last_loop 1084290213, now: 1084290219, retry_count: 1
May 11 10:43:39 yee gdm[9300]: gdm_slave_start: Starting slave process for :0
May 11 10:43:39 yee gdm[9300]: gdm_slave_start: Loop Thingie
May 11 10:43:39 yee gdm[9300]: Sending VT_NUM == -1 for slave 9300
May 11 10:43:39 yee gdm[9300]: Sending VT_NUM 9300 -1
May 11 10:43:39 yee gdm[9294]: gdm_display_manage: Forked slave: 9300
May 11 10:43:39 yee gdm[9294]: Handling message: 'START_NEXT_LOCAL'
May 11 10:43:39 yee gdm[9294]: Handling message: 'VT_NUM 9300 -1'
May 11 10:43:39 yee gdm[9294]: Got VT_NUM == -1
May 11 10:43:39 yee gdm[9300]: gdm_server_start: :0
May 11 10:43:39 yee gdm[9294]: (child 9300) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:39 yee gdm[9300]: gdm_auth_secure_display: Setting up access for :0
May 11 10:43:39 yee gdm[9300]: gdm_auth_secure_display: Setting up access
May 11 10:43:39 yee gdm[9300]: gdm_auth_secure_display: Setting up access for :0 - 1 entries
May 11 10:43:39 yee gdm[9300]: Sending COOKIE == <secret> for slave 9300
May 11 10:43:39 yee gdm[9300]: Sending COOKIE 9300 11...
May 11 10:43:39 yee gdm[9294]: Handling message: 'COOKIE 9300 11...'
May 11 10:43:39 yee gdm[9294]: Got COOKIE == <secret>
May 11 10:43:39 yee gdm[9294]: (child 9300) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:39 yee gdm[9302]: gdm_server_spawn: '/usr/X11R6/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt8'
May 11 10:43:39 yee gdm[9300]: gdm_server_spawn: Forked server on pid 9302
May 11 10:43:40 yee gdm[9300]: do_server_wait: Before mainloop waiting for server
May 11 10:43:41 yee gdm[9294]: (child 9300) gdm_server_child_handler: Got SIGCHLD
May 11 10:43:41 yee gdm[9294]: (child 9300) gdm_slave_child_handler
May 11 10:43:41 yee gdm[9294]: (child 9300) gdm_slave_child_handler: 9302 died
May 11 10:43:41 yee gdm[9294]: (child 9300) gdm_slave_child_handler: 9302 returned 1
May 11 10:43:41 yee gdm[9294]: Handling message: 'XPID 9300 0'
May 11 10:43:41 yee gdm[9294]: Got XPID == 0
May 11 10:43:41 yee gdm[9300]: gdm_server_start: After mainloop waiting for server
May 11 10:43:41 yee gdm[9294]: (child 9300) gdm_slave_usr2_handler: :0 got USR2 signal
May 11 10:43:41 yee gdm[9300]: gdm_server_start: Server :0 died during startup!
May 11 10:43:41 yee gdm[9300]: Display :0 is busy. There is another X server running already.
May 11 10:47:46 yee gdm[9300]: term_quit: Final cleanup
May 11 10:47:46 yee gdm[9300]: gdm_slave_quick_exit: Will kill everything from the display
May 11 10:47:46 yee gdm[9300]: gdm_slave_quick_exit: Killed everything from the display
May 11 10:47:46 yee gdm[9294]: mainloop_sig_callback: Got signal 17
May 11 10:47:46 yee gdm[9294]: gdm_cleanup_children: child 9300 returned 4
May 11 10:47:46 yee gdm[9294]: gdm_child_action: Aborting display :0
May 11 10:47:46 yee gdm[9294]: gdm_display_unmanage: Stopping :0 (slave pid: 0)
May 11 10:47:46 yee gdm[9294]: gdm_display_unmanage: Display stopped
May 11 10:47:46 yee gdm[9294]: (child 9300) gdm_slave_term_handler: :0 got TERM/INT signal
*****end quote******

This is what ps -axf shows:
*****start quote*****
9294 ? S 0:00 gdm-binary
9300 ? S 0:00 \_ gdm-binary
9305 ? S 0:00 \_ /usr/libexec/gdmopen -l /bin/sh -c /usr/bin/dialog --yesno 'There already appears to be an X server running on display :0. Should I try another display number? If you answer no, I will attempt to start the server on :0 again.
9306 tty8 S 0:00 \_ /usr/libexec/gdmopen -l /bin/sh -c /usr/bin/dialog --yesno 'There already appears to be an X server running on display :0. Should I try another display number? If you answer no, I will attempt to start the server on :0 again.
9296 ? SL 0:02 /usr/X11R6/bin/X :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
*****end quote******
I have checked XFree86 logs and everything seems fine. The logs for gdm at /var/log/gdm show that the X server is been loaded twice (that I think is also shown in the output above) for some reason:
*****start quote*****
/var/log/gdm/:0.log shows
Fatal server error:
Server is already active for display 1
If this server is no longer running, remove /tmp/.X1-lock
and start again.
*****end quote******

while /var/log/gdm/:0.log.1 looks normal (loading /etc/X11/XF86Config) and is the one responsible for that .X1-lock file.

I have no idea what might be causing this, specially the extra X server calls. Any ideas? Thanks...

</x-tad-bigger>
______________________________________________

Randall Espinoza
Department of Physics
University of Illinois at Chicago
______________________________________________

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]